Debian DLA-3168-1: openvswitch - LTS セキュリティ更新

high Nessus プラグイン ID 166707

概要

リモートの Debian ホストにセキュリティ関連の更新プログラムがありません。

説明

リモートの Debian 10 ホストには、dla-3168 のアドバイザリに記載された脆弱性の影響を受けるパッケージがインストールされています。

- ovs バージョン v0.90.0 から v2.5.0 では、flow.c のヒープバッファオーバーリードに対して脆弱です。minimasks 関数の安全でない比較により、メモリのマッピングされていない領域にアクセスされる可能性があります。この脆弱性はソフトウェアのクラッシュ、メモリ改ざん、リモート実行の可能性があります。(CVE-2022-32166)

Nessus はこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

openvswitch パッケージをアップグレードしてください。

Debian 10 buster では、この問題はバージョン 2.10.7+ds1-0+deb10u2 で修正されています。

関連情報

https://security-tracker.debian.org/tracker/source-package/openvswitch

https://www.debian.org/lts/security/2022/dla-3168

https://security-tracker.debian.org/tracker/CVE-2022-32166

https://packages.debian.org/source/buster/openvswitch

プラグインの詳細

深刻度: High

ID: 166707

ファイル名: debian_DLA-3168.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2022/10/30

更新日: 2022/11/30

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 9

Temporal Score: 6.7

ベクトル: AV:N/AC:L/Au:S/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-32166

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:openvswitch-common, p-cpe:/a:debian:debian_linux:openvswitch-dbg, p-cpe:/a:debian:debian_linux:openvswitch-dev, p-cpe:/a:debian:debian_linux:openvswitch-pki, p-cpe:/a:debian:debian_linux:openvswitch-switch, p-cpe:/a:debian:debian_linux:openvswitch-testcontroller, p-cpe:/a:debian:debian_linux:openvswitch-vtep, p-cpe:/a:debian:debian_linux:ovn-central, p-cpe:/a:debian:debian_linux:ovn-controller-vtep, p-cpe:/a:debian:debian_linux:ovn-host, p-cpe:/a:debian:debian_linux:python-openvswitch, p-cpe:/a:debian:debian_linux:python3-openvswitch, cpe:/o:debian:debian_linux:10.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/10/29

脆弱性公開日: 2022/9/28

参照情報

CVE: CVE-2022-32166