Debian DLA-3167-1: ncurses - LTS セキュリティ更新

high Nessus プラグイン ID 166708

概要

リモートの Debian ホストにセキュリティ関連の更新プログラムがありません。

説明

リモートの Debian 10 ホストには、dla-3167 のアドバイザリに記載された脆弱性の影響を受けるパッケージがインストールされています。

- パッチ 20220416 より前の ncurses 6.3 には、terminfo ライブラリの tinfo/read_entry.c の convert_strings に領域外読み取りおよびセグメンテーション違反があります。(CVE-2022-29458)

Nessus はこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

ncurses パッケージをアップグレードしてください。

Debian 10 buster では、この問題はバージョン 6.1+20181013-2+deb10u3 で修正されています。

関連情報

https://security-tracker.debian.org/tracker/source-package/ncurses

https://www.debian.org/lts/security/2022/dla-3167

https://security-tracker.debian.org/tracker/CVE-2022-29458

https://packages.debian.org/source/buster/ncurses

プラグインの詳細

深刻度: High

ID: 166708

ファイル名: debian_DLA-3167.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2022/10/30

更新日: 2022/10/30

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 6

CVSS v2

リスクファクター: Medium

Base Score: 5.8

Temporal Score: 4.3

ベクトル: AV:N/AC:M/Au:N/C:P/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-29458

CVSS v3

リスクファクター: High

Base Score: 7.1

Temporal Score: 6.2

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:lib32ncurses-dev, p-cpe:/a:debian:debian_linux:lib32ncurses6, p-cpe:/a:debian:debian_linux:lib32ncursesw6, p-cpe:/a:debian:debian_linux:lib32tinfo6, p-cpe:/a:debian:debian_linux:lib64ncurses-dev, p-cpe:/a:debian:debian_linux:lib64ncurses6, p-cpe:/a:debian:debian_linux:lib64ncursesw6, p-cpe:/a:debian:debian_linux:lib64tinfo6, p-cpe:/a:debian:debian_linux:libncurses-dev, p-cpe:/a:debian:debian_linux:libncurses5, p-cpe:/a:debian:debian_linux:libncurses5-dev, p-cpe:/a:debian:debian_linux:libncurses6, p-cpe:/a:debian:debian_linux:libncurses6-dbg, p-cpe:/a:debian:debian_linux:libncursesw5, p-cpe:/a:debian:debian_linux:libncursesw5-dev, p-cpe:/a:debian:debian_linux:libncursesw6, p-cpe:/a:debian:debian_linux:libncursesw6-dbg, p-cpe:/a:debian:debian_linux:libtinfo-dev, p-cpe:/a:debian:debian_linux:libtinfo5, p-cpe:/a:debian:debian_linux:libtinfo6, p-cpe:/a:debian:debian_linux:libtinfo6-dbg, p-cpe:/a:debian:debian_linux:ncurses-base, p-cpe:/a:debian:debian_linux:ncurses-bin, p-cpe:/a:debian:debian_linux:ncurses-doc, p-cpe:/a:debian:debian_linux:ncurses-examples, p-cpe:/a:debian:debian_linux:ncurses-term, cpe:/o:debian:debian_linux:10.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/10/29

脆弱性公開日: 2022/4/18

参照情報

CVE: CVE-2022-29458