CentOS 8 : php: 8.0 (CESA-2022: 7624)

critical Nessus プラグイン ID 167147

概要

リモートの CentOS ホストに 1 つ以上のセキュリティ更新プログラムが欠落しています。

説明

リモートの CentOS Linux 8 ホストにインストールされているパッケージは、CESA-2022: 7624 のアドバイザリに記載されている脆弱性の影響を受けます。

- php: php_filter_float() が ints に失敗するためにメモリ解放後使用 (Use After Free) (CVE-2021-21708)

- php: pg_query_params() の配列が初期化されていないため RCE が発生 (CVE-2022-31625)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://access.redhat.com/errata/RHSA-2022:7624

プラグインの詳細

深刻度: Critical

ID: 167147

ファイル名: centos8_RHSA-2022-7624.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2022/11/9

更新日: 2022/11/9

サポートされているセンサー: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Agentless Assessment

リスク情報

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: CVSS2#E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-31625

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

CVSS スコアのソース: CVE-2021-21708

脆弱性情報

CPE: p-cpe:2.3:a:centos:centos:php:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-gd:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-ldap:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-mbstring:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-odbc:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-pear:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-pgsql:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-snmp:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-bcmath:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-cli:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-common:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-dba:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-pdo:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-soap:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-xml:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-embedded:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-enchant:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-fpm:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-intl:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-process:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-mysqlnd:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:apcu-panel:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:libzip:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:libzip-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:libzip-tools:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-dbg:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-gmp:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-opcache:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-pecl-apcu:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-pecl-apcu-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-pecl-zip:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-pecl-rrd:*:*:*:*:*:*:*, cpe:2.3:o:centos:centos:8-stream:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-ffi:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:php-pecl-xdebug3:*:*:*:*:*:*:*

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/CentOS/release, Host/CentOS/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/11/8

脆弱性公開日: 2022/2/27

参照情報

CVE: CVE-2021-21708, CVE-2022-31625

RHSA: 2022:7624