CentOS 8: grafana (CESA-2022:7519)

high Nessus プラグイン ID 167149

概要

リモートの CentOS ホストに 1 つ以上のセキュリティ更新プログラムが欠落しています。

説明

リモートの CentOS Linux 8 ホストにインストールされているパッケージは、CESA-2022: 7519 のアドバイザリに記載されている複数の脆弱性の影響を受けます。

- sanitize-url: sanitizeUrl 関数の不適切なサニタイズによる XSS (CVE-2021-23648)

- golang: net/http: Transfer-Encoding ヘッダーの不適切なサニタイズ (CVE-2022-1705)

- golang: go/parser: すべての Parse * 関数におけるスタックの枯渇 (CVE-2022-1962)

- grafana:Forward OAuth Identity Token により、ユーザーは一部のデータソースにアクセスできる場合があります (CVE-2022-21673)

- prometheus/client_golang: InstrumentHandlerCounter を使用したサービス拒否 (CVE-2022-21698)

- grafana:データソース処理における XSS の脆弱性 (CVE-2022-21702)

- grafana:CSRF の脆弱性により、権限昇格につながる可能性があります (CVE-2022-21703)

- grafana:IDOR の脆弱性により、情報漏洩が発生する可能性があります (CVE-2022-21713)

- golang: encoding/xml: Decoder.Skip でのスタックの枯渇 (CVE-2022-28131)

- golang: io/fs: Glob でのスタックの枯渇 (CVE-2022-30630)

- golang: compress/gzip: Reader.Read のスタックの枯渇 (CVE-2022-30631)

- golang: path/filepath: Glob でのスタックの枯渇 (CVE-2022-30632)

- golang: encoding/xml: Unmarshal でのスタックの枯渇 (CVE-2022-30633)

- golang: encoding/gob: Decoder.Decode でのスタックの枯渇 (CVE-2022-30635)

- golang: net/http/httputil: NewSingleHostReverseProxy - 機能していない X-Forwarded-For の除外 (CVE-2022-32148)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受ける grafana パッケージを更新してください。

関連情報

https://access.redhat.com/errata/RHSA-2022:7519

プラグインの詳細

深刻度: High

ID: 167149

ファイル名: centos8_RHSA-2022-7519.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2022/11/9

更新日: 2022/11/9

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-21703

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:centos:centos:8-stream, p-cpe:/a:centos:centos:grafana

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/11/8

脆弱性公開日: 2022/1/18

参照情報

CVE: CVE-2021-23648, CVE-2022-1705, CVE-2022-1962, CVE-2022-21673, CVE-2022-21698, CVE-2022-21702, CVE-2022-21703, CVE-2022-21713, CVE-2022-28131, CVE-2022-30630, CVE-2022-30631, CVE-2022-30632, CVE-2022-30633, CVE-2022-30635, CVE-2022-32148

RHSA: 2022:7519