CentOS 8 : container-tools:3.0 (CESA-2022: 7529)

medium Nessus プラグイン ID 167185

概要

リモートの CentOS ホストに 1 つ以上のセキュリティ更新プログラムが欠落しています。

説明

リモートの CentOS Linux 8 ホストにインストールされているパッケージは、CESA-2022: 7529 のアドバイザリに記載されている脆弱性の影響を受けます。

- golang: net/http: Transfer-Encoding ヘッダーの不適切なサニタイズ (CVE-2022-1705)

- cri-o: kube api にアクセスする際のノードのメモリ枯渇 (CVE-2022-1708)

- golang: go/parser: すべての Parse * 関数におけるスタックの枯渇 (CVE-2022-1962)

- prometheus/client_golang: InstrumentHandlerCounter を使用したサービス拒否 (CVE-2022-21698)

- golang: encoding/xml: Decoder.Skip でのスタックの枯渇 (CVE-2022-28131)

- golang: io/fs: Glob でのスタックの枯渇 (CVE-2022-30630)

- golang: compress/gzip: Reader.Read のスタックの枯渇 (CVE-2022-30631)

- golang: path/filepath: Glob でのスタックの枯渇 (CVE-2022-30632)

- golang: encoding/xml: Unmarshal でのスタックの枯渇 (CVE-2022-30633)

- golang: net/http/httputil: NewSingleHostReverseProxy - 機能していない X-Forwarded-For の除外 (CVE-2022-32148)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://access.redhat.com/errata/RHSA-2022:7529

プラグインの詳細

深刻度: Medium

ID: 167185

ファイル名: centos8_RHSA-2022-7529.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2022/11/9

更新日: 2023/2/8

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure

リスク情報

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: High

Base Score: 7.8

Temporal Score: 5.8

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-1708

CVSS v3

リスクファクター: Medium

Base Score: 6.5

Temporal Score: 5.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

現状ベクトル: E:U/RL:O/RC:C

CVSS スコアのソース: CVE-2022-32148

脆弱性情報

CPE: cpe:/o:centos:centos:8-stream, p-cpe:/a:centos:centos:buildah, p-cpe:/a:centos:centos:buildah-tests, p-cpe:/a:centos:centos:cockpit-podman, p-cpe:/a:centos:centos:conmon, p-cpe:/a:centos:centos:container-selinux, p-cpe:/a:centos:centos:containernetworking-plugins, p-cpe:/a:centos:centos:containers-common, p-cpe:/a:centos:centos:crit, p-cpe:/a:centos:centos:criu, p-cpe:/a:centos:centos:crun, p-cpe:/a:centos:centos:fuse-overlayfs, p-cpe:/a:centos:centos:libslirp, p-cpe:/a:centos:centos:libslirp-devel, p-cpe:/a:centos:centos:oci-seccomp-bpf-hook, p-cpe:/a:centos:centos:podman, p-cpe:/a:centos:centos:podman-catatonit, p-cpe:/a:centos:centos:podman-docker, p-cpe:/a:centos:centos:podman-plugins, p-cpe:/a:centos:centos:podman-remote, p-cpe:/a:centos:centos:podman-tests, p-cpe:/a:centos:centos:python3-criu, p-cpe:/a:centos:centos:skopeo, p-cpe:/a:centos:centos:skopeo-tests, p-cpe:/a:centos:centos:slirp4netns, p-cpe:/a:centos:centos:udica

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/11/8

脆弱性公開日: 2022/2/15

参照情報

CVE: CVE-2022-1705, CVE-2022-1708, CVE-2022-1962, CVE-2022-21698, CVE-2022-28131, CVE-2022-30630, CVE-2022-30631, CVE-2022-30632, CVE-2022-30633, CVE-2022-32148

RHSA: 2022:7529