DebianDLA-3186-1: exiv2 - LTSセキュリティ更新

high Nessus プラグイン ID 167277

概要

リモートの Debian ホストにセキュリティ関連の更新プログラムがありません。

説明

リモートの Debian 10 ホストには、dla-3186 のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- Internal: : TiffReader:: visitDirectory 関数 (Exiv2 0.26 の tiffvisitor.cpp 内) に、到達可能なアサーションがあります。これにより、細工された入力を介してリモートのサービス拒否が引き起こされる可能性があります。(CVE-2017-11683)

- Exiv2 v0.27.1 の Types.cpp の Databuf 関数におけるバッファオーバーフローの脆弱性により、サービス拒否 (DOS) が引き起こされます。(CVE-2020-19716)

- Exiv2 に脆弱性が見つかりました。重要度最高と分類されています。影響を受けるのは、QuickTime Video Handler コンポーネントの quicktimevideo.cpp ファイルの QuickTimeVideo: : userDataDecoder 関数です。
この操作により整数オーバーフローが発生します。リモートで攻撃を仕掛けることが可能です。パッチの名前は、bf4f28b727bdedbd7c88179c30d360e54568a62e です。この問題を修正するパッチを適用することが推奨されます。
この脆弱性の識別子は VDB-212496 です。(CVE-2022-3756)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

exiv2パッケージをアップグレードしてください。

Debian 10 buster では、これらの問題はバージョン 0.25-4+deb10u3 で修正されています。

関連情報

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=876893

https://security-tracker.debian.org/tracker/source-package/exiv2

https://www.debian.org/lts/security/2022/dla-3186

https://security-tracker.debian.org/tracker/CVE-2017-11683

https://security-tracker.debian.org/tracker/CVE-2020-19716

https://security-tracker.debian.org/tracker/CVE-2022-3756

https://packages.debian.org/source/buster/exiv2

プラグインの詳細

深刻度: High

ID: 167277

ファイル名: debian_DLA-3186.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2022/11/11

更新日: 2022/11/11

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.2

ベクトル: AV:N/AC:M/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2020-19716

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

CVSS スコアのソース: CVE-2022-3756

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:exiv2, p-cpe:/a:debian:debian_linux:libexiv2-14, p-cpe:/a:debian:debian_linux:libexiv2-dev, p-cpe:/a:debian:debian_linux:libexiv2-doc, cpe:/o:debian:debian_linux:10.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/11/10

脆弱性公開日: 2017/7/27

参照情報

CVE: CVE-2017-11683, CVE-2020-19716, CVE-2022-3756