Debian DLA-3188-1: sysstat - LTS セキュリティ更新

critical Nessus プラグイン ID 167432

概要

リモートの Debian ホストにセキュリティ関連の更新プログラムがありません。

説明

リモートの Debian 10 ホストには、dla-3188 のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- 12.1.6より前の sysstat には、sa_common.c の remap_struct() で発生する整数オーバーフローによるメモリ破損があります。
(CVE-2019-16167)

- 12.2.0 までの sysstat は、sa_common.c の check_file_actlst で二重解放があります。(CVE-2019-19725)

- sysstat は、Linux オペレーティングシステム用のシステムパフォーマンスツールのセットです。12.7.1 より前のバージョン 9.1.16 以降の 32 ビットシステムでは、allocate_structures の sa_common.c に size_t オーバーフローが含まれています。allocate_structures 関数は、算術乗算の前に境界を十分にチェックしていないため、システムアクティビティを表すバッファに割り当てられたサイズにオーバーフローが発生する可能性があります。この問題により、リモートコード実行 (RCE) が引き起こされる可能性があります。この問題には、バージョン 12.7.1 でパッチが適用されています。(CVE-2022-39377)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

sysstat パッケージをアップグレードしてください。

Debian 10 buster では、これらの問題はバージョン 12.0.3-2+deb10u1 で修正されています。

関連情報

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=939914

https://security-tracker.debian.org/tracker/source-package/sysstat

https://www.debian.org/lts/security/2022/dla-3188

https://security-tracker.debian.org/tracker/CVE-2019-16167

https://security-tracker.debian.org/tracker/CVE-2019-19725

https://security-tracker.debian.org/tracker/CVE-2022-39377

https://packages.debian.org/source/buster/sysstat

プラグインの詳細

深刻度: Critical

ID: 167432

ファイル名: debian_DLA-3188.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2022/11/14

更新日: 2022/11/14

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2019-19725

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:isag, p-cpe:/a:debian:debian_linux:sysstat, cpe:/o:debian:debian_linux:10.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/11/14

脆弱性公開日: 2019/9/9

参照情報

CVE: CVE-2019-16167, CVE-2019-19725, CVE-2022-39377