Debian DSA-5277-1: php7.4 - セキュリティ更新

critical Nessus プラグイン ID 167434

概要

リモートの Debian ホストに 1 つまたは複数のセキュリティ関連の更新プログラムがありません。

説明

リモートの Debian 11 ホストには、dsa-5277 のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- 7.4.31、8.0.24、および 8.1.11より前のバージョンの PHP では、phar 解凍プログラムのコードが quines gzip ファイルを再帰的に解凍し、無限ループが発生していました。(CVE-2022-31628)

- 7.4.31、8.0.24 および 8.1.11より前のバージョンの PHP では、この脆弱性により、ネットワークおよび同一サイト攻撃者が、PHP アプリケーションによって「__Host-」または「__Secure-」クッキーとして扱われる標準の安全でないクッキーを被害者のブラウザに設定する可能性があります。(CVE-2022-31629)

- fdc6fef より前の Keccak XKCP SHA-3 参照実装には、整数オーバーフローおよび結果として生じるバッファオーバーフローがあり、攻撃者が任意のコードを実行したり、予期される暗号プロパティを排除したりする可能性があります。
これは、スポンジ関数インターフェースで発生します。(CVE-2022-37454)

- imageloadfont() 関数内の境界条件により、脆弱性が存在します。リモートの攻撃者が、特別に細工されたデータを Web アプリケーションに渡し、領域外読み取りエラーをトリガーし、システム上のメモリのコンテンツを読み取る可能性があります。(CVE-2022-31630)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

php7.4 パッケージをアップグレードしてください。

安定版 (stable) ディストリビューション (bullseye) では、これらの問題はバージョン 7.4.33-1+deb11u1 で修正されています。

関連情報

https://security-tracker.debian.org/tracker/source-package/php7.4

https://packages.debian.org/source/bullseye/php7.4

https://security-tracker.debian.org/tracker/CVE-2022-37454

https://www.debian.org/security/2022/dsa-5277

https://security-tracker.debian.org/tracker/CVE-2022-31628

https://security-tracker.debian.org/tracker/CVE-2022-31629

https://security-tracker.debian.org/tracker/CVE-2022-31630

プラグインの詳細

深刻度: Critical

ID: 167434

ファイル名: debian_DSA-5277.nasl

バージョン: 1.6

タイプ: local

エージェント: unix

公開日: 2022/11/14

更新日: 2023/1/12

サポートされているセンサー: Frictionless Assessment Agent, Nessus Agent, Agentless Assessment

リスク情報

VPR

リスクファクター: High

スコア: 8.4

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 7.4

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: CVSS2#E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-37454

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:libapache2-mod-php7.4:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:libphp7.4-embed:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-bcmath:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-bz2:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-cgi:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-cli:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-common:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-curl:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-dba:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-dev:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-enchant:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-fpm:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-gd:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-gmp:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-imap:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-interbase:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-intl:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-json:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-ldap:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-mbstring:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-mysql:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-odbc:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-opcache:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-pgsql:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-phpdbg:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-pspell:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-readline:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-snmp:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-soap:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-sqlite3:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-sybase:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-tidy:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-xml:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-xmlrpc:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-xsl:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:php7.4-zip:*:*:*:*:*:*:*

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/11/13

脆弱性公開日: 2022/9/28

参照情報

CVE: CVE-2022-31628, CVE-2022-31629, CVE-2022-37454, CVE-2022-31630

IAVA: 2022-A-0515-S