Debian DSA-5290-1: commons-configuration2 - セキュリティ更新

critical Nessus プラグイン ID 168228

概要

リモートの Debian ホストにセキュリティ関連の更新プログラムがありません。

説明

リモートの Debian 11 ホストには、dsa-5290 のアドバイザリに記載された脆弱性の影響を受けるパッケージがインストールされています。

- Apache Commons Configuration は変数補間を実行し、プロパティを動的に評価および拡張できます。補間の標準形式は ${prefix: name} です。ここで、prefix は、補間を実行する org.apache.commons.configuration2.interpol.Lookup のインスタンスを見つけるために使用されます。バージョン 2.4 から 2.7 までは、デフォルトの Lookup インスタンスのセットにインターポレーターが含まれ、任意のコードの実行またはリモートサーバーとの接続を引き起こす可能性があります。これらの検索は以下の通りです。- スクリプト - JVM スクリプト実行エンジン (javax.script) を使用して式を実行します - dns
- dns レコードを解決します - url - リモートサーバーからも含めて、urls から値を読み込みます。影響を受けるバージョンで補間デフォルトを使用しているアプリケーションは、リモートコードの実行や、信頼できない構成値が使用された場合のリモートサーバーとの意図しない接続に対して脆弱な場合があります。ユーザーは、問題のあるインターポレーターをデフォルトで無効にする Apache Commons Configuration 2.8.0 にアップグレードすることが推奨されます。(CVE-2022-33980)

Nessus はこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

commons-configuration2 パッケージをアップグレードしてください。

安定版 (stable) ディストリビューション (bullseye) では、これらの問題はバージョン 2.8.0-1~deb11u1 で修正されています。

関連情報

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1014960

http://www.nessus.org/u?a8d47290

https://www.debian.org/security/2022/dsa-5290

https://security-tracker.debian.org/tracker/CVE-2022-33980

https://packages.debian.org/source/bullseye/commons-configuration2

プラグインの詳細

深刻度: Critical

ID: 168228

ファイル名: debian_DSA-5290.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2022/11/28

更新日: 2022/11/28

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

リスク情報

VPR

リスクファクター: Critical

スコア: 9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-33980

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:libcommons-configuration2-java, p-cpe:/a:debian:debian_linux:libcommons-configuration2-java-doc, cpe:/o:debian:debian_linux:11.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/11/28

脆弱性公開日: 2022/7/6

参照情報

CVE: CVE-2022-33980