Debian DLA-3212-1 : twisted - LTS セキュリティ更新

medium Nessus プラグイン ID 168233

概要

リモートの Debian ホストにセキュリティ関連の更新プログラムがありません。

説明

リモートの Debian 10 ホストには、dla-3212 のアドバイザリに記載された脆弱性の影響を受けるパッケージがインストールされています。

- Twisted は、イベントベースのインターネットアプリケーション用フレームワークです。バージョン 0.9.4 で開始し、ホストヘッダーが構成済みのホスト「twisted.web.vhost.NameVirtualHost」と一致しない場合、「NoResource」リソースを返すため、ホストヘッダーが 404 応答にエスケープされず、HTML とスクリプトのインジェクションが可能になります。
実際には、これを悪用することは非常に困難です。通常の HTTP リクエストのホストヘッダーを変更できるということは、すでに権限のある立場にいることを意味しているからです。この問題は、バージョン 22.10.0rc1 で修正されました。既知の回避策はありません。(CVE-2022-39348)

Nessus はこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

twisted パッケージをアップグレードしてください。

Debian 10 buster では、この問題はバージョン 18.9.0-3+deb10u2 で修正されています。

関連情報

https://security-tracker.debian.org/tracker/source-package/twisted

https://www.debian.org/lts/security/2022/dla-3212

https://security-tracker.debian.org/tracker/CVE-2022-39348

https://packages.debian.org/source/buster/twisted

プラグインの詳細

深刻度: Medium

ID: 168233

ファイル名: debian_DLA-3212.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2022/11/28

更新日: 2022/11/28

サポートされているセンサー: Frictionless Assessment Agent, Nessus Agent, Agentless Assessment

リスク情報

VPR

リスクファクター: Low

スコア: 3.8

CVSS v2

リスクファクター: Medium

Base Score: 5.5

Temporal Score: 4.1

ベクトル: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:N

現状ベクトル: CVSS2#E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-39348

CVSS v3

リスクファクター: Medium

Base Score: 5.4

Temporal Score: 4.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:python-twisted:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:python-twisted-bin:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:python-twisted-bin-dbg:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:python-twisted-conch:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:python-twisted-core:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:python-twisted-mail:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:python-twisted-names:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:python-twisted-news:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:python-twisted-runner:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:python-twisted-runner-dbg:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:python-twisted-web:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:python-twisted-words:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:twisted-doc:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:python3-twisted:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:python3-twisted-bin:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:python3-twisted-bin-dbg:*:*:*:*:*:*:*

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/11/28

脆弱性公開日: 2022/10/26

参照情報

CVE: CVE-2022-39348