Debian DSA-5409-1 : libssh - セキュリティ更新

medium Nessus プラグイン ID 176333

概要

リモートの Debian ホストにセキュリティ関連の更新プログラムがありません。

説明

リモートの Debian 11 ホストには、dsa-5409 のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- アルゴリズム推測による鍵の再生成中の NULL ポインターデリファレンス [fedora-all] (CVE-2023-1667)

- pki_verify_data_signature の認証バイパス [fedora-all] (CVE-2023-2283)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

libssh パッケージをアップグレードしてください。

安定版 (stable) ディストリビューション (bullseye) では、これらの問題はバージョン 0.9.7-0+deb11u1 で修正されています。

参考資料

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1035832

https://security-tracker.debian.org/tracker/source-package/libssh

https://www.debian.org/security/2023/dsa-5409

https://security-tracker.debian.org/tracker/CVE-2023-1667

https://security-tracker.debian.org/tracker/CVE-2023-2283

https://packages.debian.org/source/bullseye/libssh

プラグインの詳細

深刻度: Medium

ID: 176333

ファイル名: debian_DSA-5409.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2023/5/24

更新日: 2023/12/22

サポートされているセンサー: Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

リスク情報

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Medium

基本値: 6.4

現状値: 5

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

CVSS スコアのソース: CVE-2023-2283

CVSS v3

リスクファクター: Medium

基本値: 6.5

現状値: 5.9

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

現状ベクトル: CVSS:3.0/E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:libssh-4, p-cpe:/a:debian:debian_linux:libssh-dev, p-cpe:/a:debian:debian_linux:libssh-doc, p-cpe:/a:debian:debian_linux:libssh-gcrypt-4, p-cpe:/a:debian:debian_linux:libssh-gcrypt-dev, cpe:/o:debian:debian_linux:11.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2023/5/23

脆弱性公開日: 2023/5/11

参照情報

CVE: CVE-2023-1667, CVE-2023-2283

IAVA: 2023-A-0517-S