Debian DSA-5575-1 : webkit2gtk - セキュリティ更新

high Nessus プラグイン ID 186738

概要

リモートの Debian ホストにセキュリティ関連の更新プログラムがありません。

説明

リモートの Debian 11 および 12 ホストには、dsa-5575 のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- 領域外読み取りは、入力検証の改善により対応されました。(CVE-2023-42916)

- メモリ破損の脆弱性は、ロッキングを改善することで対処されました。(CVE-2023-42917)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存していることに注意してください。

ソリューション

webkit2gtk パッケージをアップグレードしてください。

安定版 (stable) ディストリビューション (bookworm) では、これらの問題はバージョン 2.42.3-1~deb12u1 で修正されています。

参考資料

https://security-tracker.debian.org/tracker/source-package/webkit2gtk

https://www.debian.org/security/2023/dsa-5575

https://security-tracker.debian.org/tracker/CVE-2023-42916

https://security-tracker.debian.org/tracker/CVE-2023-42917

https://packages.debian.org/source/bullseye/webkit2gtk

https://packages.debian.org/source/bookworm/webkit2gtk

プラグインの詳細

深刻度: High

ID: 186738

ファイル名: debian_DSA-5575.nasl

バージョン: 1.1

タイプ: local

エージェント: unix

公開日: 2023/12/11

更新日: 2024/2/28

サポートされているセンサー: Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

リスク情報

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: Critical

基本値: 10

現状値: 8.3

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS スコアのソース: CVE-2023-42917

CVSS v3

リスクファクター: High

基本値: 8.8

現状値: 8.2

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:F/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:debian:debian_linux:11.0, p-cpe:/a:debian:debian_linux:libwebkit2gtk-4.1-0, p-cpe:/a:debian:debian_linux:gir1.2-webkit2-4.0, p-cpe:/a:debian:debian_linux:gir1.2-javascriptcoregtk-4.0, p-cpe:/a:debian:debian_linux:libjavascriptcoregtk-4.0-bin, p-cpe:/a:debian:debian_linux:libjavascriptcoregtk-4.1-0, cpe:/o:debian:debian_linux:12.0, p-cpe:/a:debian:debian_linux:webkit2gtk-driver, p-cpe:/a:debian:debian_linux:libwebkitgtk-6.0-dev, p-cpe:/a:debian:debian_linux:libjavascriptcoregtk-6.0-1, p-cpe:/a:debian:debian_linux:libjavascriptcoregtk-4.1-dev, p-cpe:/a:debian:debian_linux:gir1.2-webkit-6.0, p-cpe:/a:debian:debian_linux:libjavascriptcoregtk-4.0-18, p-cpe:/a:debian:debian_linux:libwebkit2gtk-4.0-dev, p-cpe:/a:debian:debian_linux:libwebkit2gtk-4.0-doc, p-cpe:/a:debian:debian_linux:gir1.2-javascriptcoregtk-4.1, p-cpe:/a:debian:debian_linux:libwebkit2gtk-4.0-37, p-cpe:/a:debian:debian_linux:gir1.2-webkit2-4.1, p-cpe:/a:debian:debian_linux:libwebkit2gtk-4.1-dev, p-cpe:/a:debian:debian_linux:libwebkitgtk-6.0-4, p-cpe:/a:debian:debian_linux:gir1.2-javascriptcoregtk-6.0, p-cpe:/a:debian:debian_linux:libjavascriptcoregtk-4.0-dev, p-cpe:/a:debian:debian_linux:libjavascriptcoregtk-6.0-dev

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2023/12/11

脆弱性公開日: 2023/11/30

CISA の既知の悪用された脆弱性の期限日: 2023/12/25

参照情報

CVE: CVE-2023-42916, CVE-2023-42917