Debian dsa-5633 : knot-resolver - セキュリティ更新

high Nessus プラグイン ID 191074

概要

リモートの Debian ホストにセキュリティ関連の更新プログラムがありません。

説明

リモートの Debian 12 ホストには、dsa-5633 のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- 5.7.0 以前の Knot Resolver は、サーバーから特定の無意味な応答を受信すると、多数の TCP 再接続を実行します。(CVE-2023-46317)

- DNS プロトコルの DNSSEC の特定の部分 (RFC 4033、4034、4035、6840 および関連する RFC) により、リモート攻撃者が、1 つ以上の DNSSEC 応答を介してサービス拒否 (CPU 消費) を引き起こすことが可能です (別名 KeyTrap)。懸念の 1 つは、多数の DNSKEY および RRSIG レコードを持つゾーンがある場合に、アルゴリズムが DNSKEY と RRSIG レコードのすべての組み合わせを評価する必要があることをプロトコルの仕様が示唆していることです。(CVE-2023-50387)

- DNS プロトコルの Closest Encloser Proof 側面 (RFC 9276 ガイダンスがスキップされた場合の RFC 5155) により、リモート攻撃者が、ランダムサブドメイン攻撃の DNSSEC 応答を介してサービス拒否 (SHA-1 計算のための CPU 消費) を引き起こすことが可能です (別名 NSEC3 問題)。RFC 5155 仕様は、アルゴリズムが特定の状況でハッシュ関数の反復を何千回も実行する必要があることを示唆しています。(CVE-2023-50868)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存していることに注意してください。

ソリューション

knot-resolve パッケージをアップグレードしてください。

参考資料

http://www.nessus.org/u?8a867234

https://security-tracker.debian.org/tracker/CVE-2023-46317

https://security-tracker.debian.org/tracker/CVE-2023-50387

https://security-tracker.debian.org/tracker/CVE-2023-50868

https://packages.debian.org/source/bookworm/knot-resolver

プラグインの詳細

深刻度: High

ID: 191074

ファイル名: debian_DSA-5633.nasl

バージョン: 1.0

タイプ: local

エージェント: unix

公開日: 2024/2/28

更新日: 2024/2/28

サポートされているセンサー: Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 5.1

CVSS v2

リスクファクター: High

基本値: 7.8

現状値: 5.8

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS スコアのソース: CVE-2023-50387

CVSS v3

リスクファクター: High

基本値: 7.5

現状値: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:knot-resolver, p-cpe:/a:debian:debian_linux:knot-resolver-doc, p-cpe:/a:debian:debian_linux:knot-resolver-module-http, cpe:/o:debian:debian_linux:12.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2024/2/27

脆弱性公開日: 2023/10/22

参照情報

CVE: CVE-2023-46317, CVE-2023-50387, CVE-2023-50868