Debian dla-3805 : libqt5concurrent5 - セキュリティ更新

critical Nessus プラグイン ID 194883

概要

リモートの Debian ホストにセキュリティ関連の更新プログラムがありません。

説明

リモートの Debian 10 ホストには、dla-3805 のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- 6.4.3 より前の Qt では、SQL ODBC ドライバープラグインが使用され、SQLTCHAR のサイズが 4 の場合、細工された文字列を介したサービス拒否が発生する可能性があります。影響を受けるバージョンは、5.15.13 より前の 5.x、6.2.8 より前の 6.x、および 6.4.3 より前の 6.3.x です。(CVE-2023-24607)

- 5.15.14より前、6.2.9 より前の 6.x、6.5.1 より前の 6.3.xから 6.5.xの Qt で問題が発見されました。Qt Network は strict-transport-security (HSTS) ヘッダーを不適切に解析するため、サーバーによって明示的に禁止されている場合でも、暗号化されていない接続を確立できていました。これは、このヘッダーに使用される大文字と小文字が完全に一致しない場合に発生します。(CVE-2023-32762)

- 5.15.15より前、6.2.9 より前の 6.x、6.5.1 より前の 6.3.xから 6.5.xの Qt で問題が発見されました。画像を含む SVG ファイルがレンダリングされると、QTextLayout のバッファオーバーフローが発生する可能性があります。
(CVE-2023-32763)

- 5.15.14 より前の 5.x、6.2.9 より前の 6.x、6.5.1 より前の 6.3.x から 6.5.x の Qt で問題が発見されました。
QDnsLookup には、DNS サーバーからの細工された返信によるバッファオーバーリードがあります。(CVE-2023-33285)

- 5.15.15 より前、6.x より前の 6.2.9、および 6.5.2 より前の 6.3.x から 6.5.x の Qt では、QXmlStreamReader で細工された XML 文字列によってアプリケーションがクラッシュし、プレフィックスが長さよりも長い状況が発生する可能性があります。(CVE-2023-37369)

- 5.15.15より前、6.2.10 より前の 6.x、6.5.3 より前の 6.3.xから 6.5.x の Qt で問題が発見されました。
再帰エンティティ拡張に無限ループがあります。(CVE-2023-38197)

5.15.17 より前、6.2.11 より前の 6.x、6.5.4 より前の 6.3.x から 6.5.x、6.6.2 より前の 6.6.x の Qt の HTTP2 実装で問題が発見されました。network/access/http2/hpacktable.cpp には、間違った HPack 整数オーバーフローチェックがあります。(CVE-2023-51714)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存していることに注意してください。

ソリューション

libqt5concurrent5 パッケージをアップグレードしてください。

参考資料

http://www.nessus.org/u?daec893f

https://security-tracker.debian.org/tracker/CVE-2023-24607

https://security-tracker.debian.org/tracker/CVE-2023-32762

https://security-tracker.debian.org/tracker/CVE-2023-32763

https://security-tracker.debian.org/tracker/CVE-2023-33285

https://security-tracker.debian.org/tracker/CVE-2023-37369

https://security-tracker.debian.org/tracker/CVE-2023-38197

https://security-tracker.debian.org/tracker/CVE-2023-51714

https://packages.debian.org/source/buster/qtbase-opensource-src

プラグインの詳細

深刻度: Critical

ID: 194883

ファイル名: debian_DLA-3805.nasl

バージョン: 1.0

タイプ: local

エージェント: unix

公開日: 2024/5/1

更新日: 2024/5/1

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent, Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Critical

基本値: 10

現状値: 7.8

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS スコアのソース: CVE-2023-51714

CVSS v3

リスクファクター: Critical

基本値: 9.8

現状値: 8.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:libqt5concurrent5, p-cpe:/a:debian:debian_linux:libqt5core5a, p-cpe:/a:debian:debian_linux:libqt5dbus5, p-cpe:/a:debian:debian_linux:libqt5gui5, p-cpe:/a:debian:debian_linux:libqt5network5, p-cpe:/a:debian:debian_linux:libqt5opengl5, p-cpe:/a:debian:debian_linux:libqt5opengl5-dev, p-cpe:/a:debian:debian_linux:libqt5printsupport5, p-cpe:/a:debian:debian_linux:libqt5sql5, p-cpe:/a:debian:debian_linux:libqt5sql5-ibase, p-cpe:/a:debian:debian_linux:libqt5sql5-mysql, p-cpe:/a:debian:debian_linux:libqt5sql5-odbc, p-cpe:/a:debian:debian_linux:libqt5sql5-psql, p-cpe:/a:debian:debian_linux:libqt5sql5-sqlite, p-cpe:/a:debian:debian_linux:libqt5sql5-tds, p-cpe:/a:debian:debian_linux:libqt5test5, p-cpe:/a:debian:debian_linux:libqt5widgets5, p-cpe:/a:debian:debian_linux:libqt5xml5, p-cpe:/a:debian:debian_linux:qt5-default, p-cpe:/a:debian:debian_linux:qt5-flatpak-platformtheme, p-cpe:/a:debian:debian_linux:qt5-gtk-platformtheme, p-cpe:/a:debian:debian_linux:qt5-qmake, p-cpe:/a:debian:debian_linux:qt5-qmake-bin, p-cpe:/a:debian:debian_linux:qtbase5-dev, p-cpe:/a:debian:debian_linux:qtbase5-dev-tools, p-cpe:/a:debian:debian_linux:qtbase5-doc, p-cpe:/a:debian:debian_linux:qtbase5-doc-html, p-cpe:/a:debian:debian_linux:qtbase5-examples, p-cpe:/a:debian:debian_linux:qtbase5-private-dev, cpe:/o:debian:debian_linux:10.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2024/5/1

脆弱性公開日: 2023/4/15

参照情報

CVE: CVE-2023-24607, CVE-2023-32762, CVE-2023-32763, CVE-2023-33285, CVE-2023-37369, CVE-2023-38197, CVE-2023-51714