Debian dsa-5695 : gir1.2-javascriptcoregtk-4.0 - セキュリティ更新

high Nessus プラグイン ID 197634

概要

リモートの Debian ホストにセキュリティ関連の更新プログラムがありません。

説明

リモートの Debian 11 / 12 ホストには、dsa-5695 のアドバイザリに記載された脆弱性の影響を受けるパッケージがインストールされています。

- ------------------------------------------------------------------------- Debian セキュリティアドバイザリ DSA-5695-1 [email protected] https://www.debian.org/security/Alberto Garcia 2024 年 5 月 22 日https://www.debian.org/security/faq
- -------------------------------------------------------------------------

パッケージ: webkit2gtk CVE ID : CVE-2024-27834

WebKitGTK ウェブエンジンに次の脆弱性が発見されました。

CVE-2024-27834

Manfred Paul 氏は、任意の読み取りおよび書き込み機能を持つ攻撃者が、ポインター認証をバイパスできる可能性があることを発見しました。

旧安定版 (oldstable) ディストリビューション (bullseye) では、この問題はバージョン 2.44.2-1~deb11u1 で修正されています。

安定版 (stable) ディストリビューション (bookworm) では、これらの問題はバージョン 2.44.2-1~deb12u1 で修正されています。

お使いの webkit2gtk パッケージをアップグレードすることをお勧めします。

webkit2gtk の詳細なセキュリティステータスについては、そのセキュリティトラッカーページを参照してください。
https://security-tracker.debian.org/tracker/webkit2gtk

Debian セキュリティアドバイザリに関する詳細、これらの更新をシステムに適用する方法、およびよくある質問については、こちらを参照してください。https://www.debian.org/security/

メーリングリスト: [email protected]

Tenable は、前述の説明ブロックを Debian セキュリティアドバイザリから直接抽出しました。

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存していることに注意してください。

ソリューション

gir1.2-javascriptcoregtk-4.0 パッケージをアップグレードしてください。

参考資料

https://packages.debian.org/source/bookworm/webkit2gtk

https://packages.debian.org/source/bullseye/webkit2gtk

https://security-tracker.debian.org/tracker/source-package/webkit2gtk

https://security-tracker.debian.org/tracker/CVE-2024-27834

プラグインの詳細

深刻度: High

ID: 197634

ファイル名: debian_DSA-5695.nasl

バージョン: 1.7

タイプ: local

エージェント: unix

公開日: 2024/5/22

更新日: 2024/5/28

サポートされているセンサー: Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 6.6

CVSS v2

リスクファクター: Medium

基本値: 5.8

現状値: 4.3

ベクトル: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:P

CVSS スコアのソース: CVE-2024-27834

CVSS v3

リスクファクター: High

基本値: 8.8

現状値: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:debian:debian_linux:11.0, p-cpe:/a:debian:debian_linux:libwebkit2gtk-4.1-0, p-cpe:/a:debian:debian_linux:gir1.2-webkit2-4.0, p-cpe:/a:debian:debian_linux:gir1.2-javascriptcoregtk-4.0, p-cpe:/a:debian:debian_linux:libjavascriptcoregtk-4.0-bin, p-cpe:/a:debian:debian_linux:libjavascriptcoregtk-4.1-0, cpe:/o:debian:debian_linux:12.0, p-cpe:/a:debian:debian_linux:webkit2gtk-driver, p-cpe:/a:debian:debian_linux:libwebkitgtk-6.0-dev, p-cpe:/a:debian:debian_linux:libjavascriptcoregtk-6.0-1, p-cpe:/a:debian:debian_linux:libjavascriptcoregtk-4.1-dev, p-cpe:/a:debian:debian_linux:gir1.2-webkit-6.0, p-cpe:/a:debian:debian_linux:libjavascriptcoregtk-4.0-18, p-cpe:/a:debian:debian_linux:libwebkit2gtk-4.0-dev, p-cpe:/a:debian:debian_linux:libwebkit2gtk-4.0-doc, p-cpe:/a:debian:debian_linux:gir1.2-javascriptcoregtk-4.1, p-cpe:/a:debian:debian_linux:libwebkit2gtk-4.0-37, p-cpe:/a:debian:debian_linux:gir1.2-webkit2-4.1, p-cpe:/a:debian:debian_linux:libwebkit2gtk-4.1-dev, p-cpe:/a:debian:debian_linux:libwebkitgtk-6.0-4, p-cpe:/a:debian:debian_linux:gir1.2-javascriptcoregtk-6.0, p-cpe:/a:debian:debian_linux:libjavascriptcoregtk-4.0-dev, p-cpe:/a:debian:debian_linux:libjavascriptcoregtk-6.0-dev

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2024/5/22

脆弱性公開日: 2024/5/14

参照情報

CVE: CVE-2024-27834