CentOS 8 : glibc (CESA-2024:3269)

high Nessus プラグイン ID 197658

概要

リモートの CentOS ホストにセキュリティ更新プログラムがありません。

説明

リモートの CentOS Linux 8 ホストにインストールされているパッケージは、CESA-2024:3269 アドバイザリに記載されている脆弱性の影響を受けます。

- バージョン 2.39 以前の GNU C ライブラリの iconv() 関数が、文字列を ISO-2022-CN-EXT 文字セットに変換する際に、渡された出力バッファを最大 4 バイトオーバーフローする可能性があります。これは、アプリをクラッシュさせたり隣接する変数を上書きしたりするために使用される可能性があります。(CVE-2024-2961)

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存していることに注意してください。

ソリューション

影響を受けるパッケージを更新してください。

参考資料

https://access.redhat.com/errata/RHSA-2024:3269

プラグインの詳細

深刻度: High

ID: 197658

ファイル名: centos8_RHSA-2024-3269.nasl

バージョン: 1.0

タイプ: local

エージェント: unix

公開日: 2024/5/22

更新日: 2024/5/22

サポートされているセンサー: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Agentless Assessment, Nessus

リスク情報

VPR

リスクファクター: Critical

スコア: 9.2

CVSS v2

リスクファクター: High

基本値: 9

現状値: 6.7

ベクトル: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

CVSS スコアのソース: CVE-2024-2961

CVSS v3

リスクファクター: High

基本値: 8.8

現状値: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:centos:centos:glibc-langpack-st, p-cpe:/a:centos:centos:glibc-langpack-sc, p-cpe:/a:centos:centos:glibc-langpack-pap, p-cpe:/a:centos:centos:glibc-langpack-uk, p-cpe:/a:centos:centos:glibc-langpack-se, p-cpe:/a:centos:centos:glibc-langpack-agr, p-cpe:/a:centos:centos:glibc-langpack-ug, p-cpe:/a:centos:centos:glibc-devel, p-cpe:/a:centos:centos:glibc-langpack-so, p-cpe:/a:centos:centos:glibc-langpack-tk, p-cpe:/a:centos:centos:glibc-langpack-xh, p-cpe:/a:centos:centos:glibc-langpack-ml, p-cpe:/a:centos:centos:glibc-langpack-lo, cpe:/o:centos:centos:8-stream, p-cpe:/a:centos:centos:glibc-langpack-anp, p-cpe:/a:centos:centos:glibc-langpack-doi, p-cpe:/a:centos:centos:glibc-langpack-eo, p-cpe:/a:centos:centos:glibc-langpack-brx, p-cpe:/a:centos:centos:glibc-langpack-kn, p-cpe:/a:centos:centos:glibc, p-cpe:/a:centos:centos:glibc-langpack-fa, p-cpe:/a:centos:centos:glibc-langpack-kab, p-cpe:/a:centos:centos:glibc-langpack-id, p-cpe:/a:centos:centos:glibc-langpack-kk, p-cpe:/a:centos:centos:glibc-langpack-miq, p-cpe:/a:centos:centos:nscd, p-cpe:/a:centos:centos:glibc-doc, p-cpe:/a:centos:centos:glibc-langpack-cy, p-cpe:/a:centos:centos:glibc-langpack-ur, p-cpe:/a:centos:centos:glibc-langpack-ka, p-cpe:/a:centos:centos:glibc-langpack-km, p-cpe:/a:centos:centos:glibc-langpack-lb, p-cpe:/a:centos:centos:glibc-langpack-ha, p-cpe:/a:centos:centos:glibc-langpack-niu, p-cpe:/a:centos:centos:glibc-langpack-wae, p-cpe:/a:centos:centos:glibc-langpack-gd, p-cpe:/a:centos:centos:glibc-langpack-dsb, p-cpe:/a:centos:centos:glibc-langpack-lg, p-cpe:/a:centos:centos:glibc-langpack-aa, p-cpe:/a:centos:centos:glibc-langpack-ht, p-cpe:/a:centos:centos:glibc-langpack-sl, p-cpe:/a:centos:centos:glibc-langpack-ga, p-cpe:/a:centos:centos:glibc-langpack-ps, p-cpe:/a:centos:centos:glibc-langpack-to, p-cpe:/a:centos:centos:glibc-langpack-mg, p-cpe:/a:centos:centos:glibc-langpack-sgs, p-cpe:/a:centos:centos:compat-libpthread-nonshared, p-cpe:/a:centos:centos:glibc-langpack-the, p-cpe:/a:centos:centos:glibc-langpack-rw, p-cpe:/a:centos:centos:glibc-langpack-cs, p-cpe:/a:centos:centos:glibc-langpack-lt, p-cpe:/a:centos:centos:glibc-headers, p-cpe:/a:centos:centos:glibc-langpack-ak, p-cpe:/a:centos:centos:glibc-langpack-ar, p-cpe:/a:centos:centos:glibc-langpack-ik, p-cpe:/a:centos:centos:glibc-langpack-as, p-cpe:/a:centos:centos:glibc-langpack-mi, p-cpe:/a:centos:centos:glibc-langpack-zh, p-cpe:/a:centos:centos:glibc-langpack-eu, p-cpe:/a:centos:centos:glibc-langpack-fur, p-cpe:/a:centos:centos:glibc-langpack-ff, p-cpe:/a:centos:centos:glibc-langpack-uz, p-cpe:/a:centos:centos:glibc-langpack-ayc, p-cpe:/a:centos:centos:glibc-langpack-de, p-cpe:/a:centos:centos:glibc-langpack-ia, p-cpe:/a:centos:centos:glibc-langpack-tig, p-cpe:/a:centos:centos:glibc-langpack-nhn, p-cpe:/a:centos:centos:glibc-langpack-ig, p-cpe:/a:centos:centos:glibc-langpack-fy, p-cpe:/a:centos:centos:glibc-langpack-ve, p-cpe:/a:centos:centos:glibc-langpack-tn, p-cpe:/a:centos:centos:glibc-langpack-tr, p-cpe:/a:centos:centos:glibc-langpack-tt, p-cpe:/a:centos:centos:glibc-locale-source, p-cpe:/a:centos:centos:glibc-langpack-tl, p-cpe:/a:centos:centos:glibc-langpack-ms, p-cpe:/a:centos:centos:glibc-langpack-shs, p-cpe:/a:centos:centos:glibc-langpack-fil, p-cpe:/a:centos:centos:glibc-langpack-te, p-cpe:/a:centos:centos:glibc-langpack-th, p-cpe:/a:centos:centos:glibc-langpack-mjw, p-cpe:/a:centos:centos:glibc-langpack-hif, p-cpe:/a:centos:centos:glibc-langpack-crh, p-cpe:/a:centos:centos:glibc-langpack-hr, p-cpe:/a:centos:centos:glibc-nss-devel, p-cpe:/a:centos:centos:glibc-langpack-az, p-cpe:/a:centos:centos:glibc-langpack-om, p-cpe:/a:centos:centos:glibc-langpack-lij, p-cpe:/a:centos:centos:glibc-langpack-el, p-cpe:/a:centos:centos:glibc-langpack-mag, p-cpe:/a:centos:centos:glibc-langpack-nn, p-cpe:/a:centos:centos:glibc-langpack-cmn, p-cpe:/a:centos:centos:glibc-langpack-be, p-cpe:/a:centos:centos:glibc-langpack-hy, p-cpe:/a:centos:centos:glibc-utils, p-cpe:/a:centos:centos:glibc-langpack-kok, p-cpe:/a:centos:centos:glibc-langpack-yo, p-cpe:/a:centos:centos:glibc-langpack-ks, p-cpe:/a:centos:centos:glibc-langpack-nb, p-cpe:/a:centos:centos:glibc-langpack-mhr, p-cpe:/a:centos:centos:glibc-langpack-szl, p-cpe:/a:centos:centos:glibc-langpack-chr, p-cpe:/a:centos:centos:glibc-langpack-dv, p-cpe:/a:centos:centos:glibc-langpack-lv, p-cpe:/a:centos:centos:glibc-langpack-ca, p-cpe:/a:centos:centos:glibc-langpack-an, p-cpe:/a:centos:centos:glibc-langpack-bn, p-cpe:/a:centos:centos:glibc-langpack-bi, p-cpe:/a:centos:centos:glibc-static, p-cpe:/a:centos:centos:glibc-langpack-fo, p-cpe:/a:centos:centos:glibc-langpack-mfe, p-cpe:/a:centos:centos:glibc-langpack-et, p-cpe:/a:centos:centos:nss_hesiod, p-cpe:/a:centos:centos:glibc-langpack-sah, p-cpe:/a:centos:centos:glibc-langpack-ne, p-cpe:/a:centos:centos:glibc-langpack-sv, p-cpe:/a:centos:centos:glibc-langpack-nan, p-cpe:/a:centos:centos:glibc-langpack-oc, p-cpe:/a:centos:centos:glibc-langpack-yue, p-cpe:/a:centos:centos:glibc-langpack-nl, p-cpe:/a:centos:centos:glibc-langpack-pa, p-cpe:/a:centos:centos:glibc-langpack-es, p-cpe:/a:centos:centos:glibc-langpack-mr, p-cpe:/a:centos:centos:glibc-langpack-mai, p-cpe:/a:centos:centos:glibc-langpack-cv, p-cpe:/a:centos:centos:glibc-langpack-sd, p-cpe:/a:centos:centos:glibc-langpack-wal, p-cpe:/a:centos:centos:glibc-langpack-yuw, p-cpe:/a:centos:centos:glibc-langpack-bs, p-cpe:/a:centos:centos:glibc-langpack-tcy, p-cpe:/a:centos:centos:glibc-langpack-hsb, p-cpe:/a:centos:centos:glibc-langpack-unm, p-cpe:/a:centos:centos:glibc-langpack-da, p-cpe:/a:centos:centos:glibc-langpack-br, p-cpe:/a:centos:centos:glibc-langpack-ku, p-cpe:/a:centos:centos:glibc-langpack-it, p-cpe:/a:centos:centos:glibc-langpack-my, p-cpe:/a:centos:centos:glibc-langpack-ta, p-cpe:/a:centos:centos:nss_db, p-cpe:/a:centos:centos:glibc-all-langpacks, p-cpe:/a:centos:centos:glibc-langpack-zu, p-cpe:/a:centos:centos:glibc-langpack-fi, p-cpe:/a:centos:centos:glibc-benchtests, p-cpe:/a:centos:centos:glibc-langpack-is, p-cpe:/a:centos:centos:glibc-langpack-ln, p-cpe:/a:centos:centos:glibc-langpack-os, p-cpe:/a:centos:centos:glibc-langpack-tpi, p-cpe:/a:centos:centos:glibc-langpack-tg, p-cpe:/a:centos:centos:glibc-langpack-ss, p-cpe:/a:centos:centos:glibc-langpack-bhb, p-cpe:/a:centos:centos:glibc-langpack-iu, p-cpe:/a:centos:centos:glibc-langpack-ti, p-cpe:/a:centos:centos:glibc-langpack-yi, p-cpe:/a:centos:centos:glibc-langpack-bg, p-cpe:/a:centos:centos:glibc-langpack-hak, p-cpe:/a:centos:centos:glibc-langpack-nso, p-cpe:/a:centos:centos:glibc-langpack-dz, p-cpe:/a:centos:centos:glibc-langpack-bho, p-cpe:/a:centos:centos:glibc-langpack-sm, p-cpe:/a:centos:centos:glibc-langpack-nr, p-cpe:/a:centos:centos:glibc-langpack-wa, p-cpe:/a:centos:centos:glibc-langpack-si, p-cpe:/a:centos:centos:glibc-langpack-gu, p-cpe:/a:centos:centos:glibc-langpack-he, p-cpe:/a:centos:centos:glibc-langpack-mn, p-cpe:/a:centos:centos:glibc-langpack-bem, p-cpe:/a:centos:centos:glibc-langpack-ko, p-cpe:/a:centos:centos:glibc-langpack-nds, p-cpe:/a:centos:centos:glibc-langpack-csb, p-cpe:/a:centos:centos:glibc-langpack-ast, p-cpe:/a:centos:centos:glibc-langpack-li, p-cpe:/a:centos:centos:glibc-langpack-hi, p-cpe:/a:centos:centos:glibc-langpack-gl, p-cpe:/a:centos:centos:glibc-langpack-mt, p-cpe:/a:centos:centos:glibc-langpack-bo, p-cpe:/a:centos:centos:glibc-langpack-hu, p-cpe:/a:centos:centos:glibc-langpack-kw, p-cpe:/a:centos:centos:glibc-common, p-cpe:/a:centos:centos:glibc-langpack-ky, p-cpe:/a:centos:centos:glibc-langpack-raj, p-cpe:/a:centos:centos:glibc-langpack-vi, p-cpe:/a:centos:centos:glibc-langpack-wo, p-cpe:/a:centos:centos:glibc-langpack-sid, p-cpe:/a:centos:centos:glibc-langpack-gv, p-cpe:/a:centos:centos:glibc-langpack-ru, p-cpe:/a:centos:centos:glibc-langpack-sat, p-cpe:/a:centos:centos:glibc-langpack-fr, p-cpe:/a:centos:centos:glibc-langpack-mni, p-cpe:/a:centos:centos:glibc-langpack-byn, p-cpe:/a:centos:centos:glibc-langpack-ce, p-cpe:/a:centos:centos:glibc-minimal-langpack, p-cpe:/a:centos:centos:glibc-langpack-am, p-cpe:/a:centos:centos:glibc-langpack-hne, p-cpe:/a:centos:centos:glibc-langpack-sk, p-cpe:/a:centos:centos:glibc-langpack-ber, p-cpe:/a:centos:centos:glibc-langpack-pl, p-cpe:/a:centos:centos:glibc-langpack-pt, p-cpe:/a:centos:centos:glibc-langpack-ja, p-cpe:/a:centos:centos:glibc-langpack-sa, p-cpe:/a:centos:centos:glibc-langpack-sw, p-cpe:/a:centos:centos:glibc-langpack-quz, p-cpe:/a:centos:centos:glibc-langpack-af, p-cpe:/a:centos:centos:glibc-gconv-extra, p-cpe:/a:centos:centos:glibc-langpack-or, p-cpe:/a:centos:centos:libnsl, p-cpe:/a:centos:centos:glibc-langpack-kl, p-cpe:/a:centos:centos:glibc-langpack-shn, p-cpe:/a:centos:centos:glibc-langpack-gez, p-cpe:/a:centos:centos:glibc-langpack-ts, p-cpe:/a:centos:centos:glibc-langpack-sr, p-cpe:/a:centos:centos:glibc-langpack-lzh, p-cpe:/a:centos:centos:glibc-langpack-ro, p-cpe:/a:centos:centos:glibc-langpack-en, p-cpe:/a:centos:centos:glibc-langpack-sq, p-cpe:/a:centos:centos:glibc-langpack-mk

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/CentOS/release, Host/CentOS/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2024/5/22

脆弱性公開日: 2024/4/5

参照情報

CVE: CVE-2024-2961

RHSA: 2024:3269