CentOS 5:firefox(CESA-2009:1095)

high Nessus プラグイン ID 43755

言語:

New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート CentOS ホストに1つ以上のセキュリティ更新がありません。

説明

複数のセキュリティ上の問題を修正する更新済みの firefox パッケージが、 Red Hat Enterprise Linux 4 および 5 で現在利用可能です。

Red Hat セキュリティレスポンスチームは、この更新には重大なセキュリティインパクトがあるものとして評価しています。

Mozilla Firefox はオープンソースの Web ブラウザです。XULRunner は、Mozilla Firefox 用の XUL Runtime 環境を提供しています。

不正な形式の Web コンテンツの処理に様々な欠陥が見つかりました。悪意のあるコンテンツが含まれる Web ページは Firefox をクラッシュさせたり、 Firefox を実行しているユーザーとして任意のコードを実行する可能性があります。
(CVE-2009-1392、 CVE-2009-1832、CVE-2009-1833、CVE-2009-1837、 CVE-2009-1838、CVE-2009-1841)

無効な形式のローカルファイルのコンテンツの処理に、複数の欠陥が見つかりました。file:// の URL を介して、ユーザーが悪意のあるローカルコンテンツを読み込んだ場合、そのコンテンツが他のローカルデータにアクセスすることが可能でした。
(CVE-2009-1835、CVE-2009-1839)

Firefox が XML User Interface Language(XUL)スクリプトを読み込む方法に、スクリプトによる権限昇格の欠陥が見つかりました。Firefox および特定のアドオンで、特定のポリシーチェックが行われない場合に悪意のあるコンテンツが読み込まれる可能性があります。(CVE-2009-1840)

Firefox の国際化ドメイン名(IDN)で特定の Unicode の文字を表示する方法に、欠陥が見つかりました。IDN に無効な文字が含まれている場合、ユーザーに信頼できるサイトを訪問していると判断してもらうために、無効な文字はスペースとして表示された可能性があります。
(CVE-2009-1834)

Firefox でプロキシサーバーからのエラー応答を処理する方法に、欠陥が見つかりました。攻撃者がプロキシサーバーを使用している Firefox インスタンスに対して中間者攻撃を行うことができる場合、攻撃者はユーザーが訪問しているサイトから機密情報を盗み取ることができる可能性があります。(CVE-2009-1836)

これらの欠陥の技術的な詳細については、Firefox 3.0.11 向けの Mozilla セキュリティアドバイザリを参照してください。Mozilla アドバイザリへのリンクは、このエラータの参照セクションにあります。

すべての Firefox ユーザーは、これらの問題を修正する Firefox バ―ジョン 3.0.11 を含む、更新済みのこれらのパッケージにアップグレードする必要があります。更新をインストールした後、変更した内容を反映させるには Firefox を再起動する必要があります。

ソリューション

影響を受ける firefox パッケージを更新してください。

関連情報

http://www.nessus.org/u?12877242

http://www.nessus.org/u?74dda8c1

プラグインの詳細

深刻度: High

ID: 43755

ファイル名: centos_RHSA-2009-1095.nasl

バージョン: 1.19

タイプ: local

エージェント: unix

公開日: 2010/1/6

更新日: 2021/1/4

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 9.3

ベクトル: AV:N/AC:M/Au:N/C:C/I:C/A:C

脆弱性情報

CPE: p-cpe:/a:centos:centos:firefox, p-cpe:/a:centos:centos:xulrunner, p-cpe:/a:centos:centos:xulrunner-devel, p-cpe:/a:centos:centos:xulrunner-devel-unstable, cpe:/o:centos:centos:5

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

パッチ公開日: 2009/6/19

脆弱性公開日: 2009/6/12

参照情報

CVE: CVE-2009-1392, CVE-2009-1832, CVE-2009-1833, CVE-2009-1834, CVE-2009-1835, CVE-2009-1836, CVE-2009-1837, CVE-2009-1838, CVE-2009-1839, CVE-2009-1840, CVE-2009-1841, CVE-2009-2043

RHSA: 2009:1095

CWE: 20, 94, 200, 264, 287, 362