Debian DSA-1866-1:kdegraphics - いくつかの脆弱性

high Nessus プラグイン ID 44731

言語 :

New! Vulnerability Priority Rating (VPR)

Tenable では、すべての脆弱性に対して動的な VPR が計算されます。VPR は脆弱性の情報を、脅威インテリジェンスや機械学習アルゴリズムと組み合わせて、攻撃時に最も悪用される可能性の高い脆弱性を予測します。詳細は、 「VPR とは何で、CVSS とはどう違うのか」を参照してください。

VPR スコア : 6.7

概要

リモート Debian ホストに、セキュリティ更新がありません。

説明

公式 KDE リリースからのグラフィックアプリである kdegraphics に、2 つのセキュリティ問題が発見されました。Common Vulnerabilities and Exposures プロジェクトは次の問題を特定しています:

- CVE-2009-0945 KSVG アニメーション要素実装は NULL ポインターデリファレンスの欠陥の影響を受けるため、任意のコードの実行を引き起こす可能性があることが判明しました。

- CVE-2009-1709 KSVG アニメーション要素実装は use-after-free 欠陥の影響を受けるため、任意のコードの実行を引き起こす可能性があることが判明しました。

ソリューション

kdegraphics パッケージをアップグレードしてください。

旧安定版(oldstable)ディストリビューション(etch)では、これらの問題はバージョン 4:3.5.5-3etch4 で修正されました。

安定版(stable)ディストリビューション(lenny)では、これらの問題は、バージョン 4:3.5.9-3+lenny2 で修正済みです。

関連情報

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=534918

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=534951

https://security-tracker.debian.org/tracker/CVE-2009-0945

https://security-tracker.debian.org/tracker/CVE-2009-1709

https://www.debian.org/security/2009/dsa-1866

プラグインの詳細

深刻度: High

ID: 44731

ファイル名: debian_DSA-1866.nasl

バージョン: 1.14

タイプ: local

エージェント: unix

公開日: 2010/2/24

更新日: 2021/1/4

依存関係: ssh_get_info.nasl

リスク情報

リスクファクター: High

VPR スコア: 6.7

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.3

ベクトル: AV:N/AC:M/Au:N/C:C/I:C/A:C

現状ベクトル: E:POC/RL:OF/RC:C

脆弱性の情報

CPE: p-cpe:/a:debian:debian_linux:kdegraphics, cpe:/o:debian:debian_linux:4.0, cpe:/o:debian:debian_linux:5.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2009/8/19

参照情報

CVE: CVE-2009-0945, CVE-2009-1709

BID: 34924, 35334

DSA: 1866

CWE: 94, 399