CentOS 3/4/5:libpng/libpng10(CESA-2010:0534)

high Nessus プラグイン ID 47741

言語:

概要

リモート CentOS ホストに1つ以上のセキュリティ更新がありません。

説明

複数のセキュリティ問題を修正する更新済みの libpng および libpng10 パッケージが Red Hat Enterprise Linux 3、4 および 5 で現在利用可能です。

Red Hat セキュリティレスポンスチームは、この更新には重大なセキュリティ上の影響があると評価しています。詳細な重要度の評価を提供する Common Vulnerability Scoring System (CVSS)のベーススコアが、「参照」セクションの CVE リンクの各脆弱性に対して利用可能です。

libpng パッケージには、ポータブル・ネットワーク・グラフィックス(PNG)の画像フォーマットファイルを作成し、操作するための関数のライブラリが収納されています。

アプリケーションが libpng ライブラリおよびプログレッシブ読み取りメソッドを使用して特定の PNG イメージをデコードする方法に、メモリ破損の欠陥が見つかりました。攻撃者は、開くと、 libpng を使用しているアプリケーションがクラッシュすることや、そのアプリケーションを実行しているユーザーの権限で任意のコードが実行される可能性がある、特別に細工された PNG イメージを作成する可能性があります。(CVE-2010-1205)

libpng ライブラリを使用しているアプリケーションが特定の高度に圧縮された補助チャンクを持つ PNG イメージをデコードする方法で、サービス拒否の欠陥が見つかりました。攻撃者が、特別に細工された PNG イメージを作成し、これにより、 libpng を使用しているアプリケーションに大量のメモリや CPU時間を消費させ、クラッシュを引き起こす可能性があります。
(CVE-2010-0205)

libpng ライブラリを使用しているアプリケーションが物理スケール(sCAL)拡張を使用する PNG イメージをデコードする方法で、メモリリークの欠陥が見つかりました。攻撃者が、特別に細工された PNG イメージを作成し、これにより、 libpng を使用しているアプリケーションにすべての利用可能なメモリを消費させ、クラッシュや終了を引き起こす可能性があります。(CVE-2010-2249)

libpng ライブラリを使用しているアプリケーションが 1 ビットインターレースの PNG イメージを処理する方法で、機密情報漏洩の欠陥が見つかりました。攻撃者が特別に細工された PNG イメージを作成し、これにより、 libpng を使用しているアプリケーションが初期化されていないメモリを漏洩する可能性があります。(CVE-2009-2042)

libpng と libpng10 のユーザーは、バックポートされたパッチが含まれるこれらの更新済みパッケージへアップグレードし、これらの問題を解決することが推奨されます。更新を有効にするには、 libpng または libpng10 を使用している実行中のすべてのアプリケーションを再起動する必要があります。

ソリューション

影響を受ける libpng と libpng10 の両方またはいずれかのパッケージを更新してください。

関連情報

http://www.nessus.org/u?5110e399

http://www.nessus.org/u?2322f6aa

http://www.nessus.org/u?916c87cf

http://www.nessus.org/u?7f4b435e

http://www.nessus.org/u?18d3537b

http://www.nessus.org/u?9388a999

http://www.nessus.org/u?aac17204

http://www.nessus.org/u?aba3d815

プラグインの詳細

深刻度: High

ID: 47741

ファイル名: centos_RHSA-2010-0534.nasl

バージョン: 1.20

タイプ: local

エージェント: unix

公開日: 2010/7/16

更新日: 2021/1/4

サポートされているセンサー: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure

リスク情報

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.1

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:C

現状ベクトル: E:POC/RL:OF/RC:C

脆弱性情報

CPE: p-cpe:/a:centos:centos:libpng, p-cpe:/a:centos:centos:libpng-devel, p-cpe:/a:centos:centos:libpng10, p-cpe:/a:centos:centos:libpng10-devel, cpe:/o:centos:centos:3, cpe:/o:centos:centos:4, cpe:/o:centos:centos:5

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2010/8/16

脆弱性公開日: 2009/6/12

参照情報

CVE: CVE-2009-2042, CVE-2010-0205, CVE-2010-1205, CVE-2010-2249

BID: 35233, 38478, 41174

RHSA: 2010:0534

CWE: 200, 399