CentOS 4 / 5:Firefox(CESA-2010:0547)

high Nessus プラグイン ID 47806
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート CentOS ホストに1つ以上のセキュリティ更新がありません。

説明

複数のセキュリティ上の問題を修正する更新済みの firefox パッケージが、 Red Hat Enterprise Linux 4 および 5 で現在利用可能です。

Red Hat セキュリティレスポンスチームは、この更新によるセキュリティ上の影響が重大だと評価しています。詳細な重要度の評価を提供する Common Vulnerability Scoring System (CVSS)のベーススコアが、「参照」セクションの CVE リンクの各脆弱性に対して利用可能です。

Mozilla Firefox はオープンソースの Web ブラウザです。XULRunner は、Mozilla Firefox 用の XUL Runtime 環境を提供しています。

不正な形式の Web コンテンツの処理に様々な欠陥が見つかりました。悪意のあるコンテンツが含まれる Web ページが、Firefox をクラッシュさせたり、 Firefox を実行しているユーザーの権限で任意のコードを実行したりする可能性があります。(CVE-2010-1208、CVE-2010-1209、CVE-2010-1211、CVE-2010-1212、CVE-2010-1214、CVE-2010-1215、CVE-2010-2752、CVE-2010-2753)

Firefox が特定の PNG イメージを解読する方法で、メモリ破損の欠陥が見つかりました。攻撃者が特別に細工された PNG イメージを作成し、それが開かれたときに、Firefox をクラッシュさせたり、 Firefox を実行しているユーザーの権限で任意のコードを実行したりする可能性があります。(CVE-2010-1205)

いくつかの同一生成元ポリシーバイパスの欠陥が Firefox に見つかりました。攻撃者が、悪意ある Web ページを作成して、被害者がそのページを表示した際に Firefox で読み込んだ別の Web サイトから個人データを盗む可能性があります。(CVE-2010-0654、CVE-2010-1207、CVE-2010-1213、 CVE-2010-2754)

Firefox がロケーションバーをユーザーに表示する方法に欠陥が見つかりました。ページのコンテンツが実際には攻撃者によってコントロールされている場合、悪意ある Web サイトがユーザーを騙して、ロケーションバーが示すサイトを表示しているとユーザーに勘違いさせる可能性があります。(CVE-2010-1206)

安全な Web ページにアクセスする際に Firefox のロケーションバーを表示する方法で、欠陥が見つかりました。悪意あるサーバーが、この欠陥を利用して、実際には違うにもかかわらず、安全なサーバーからデータが抽出されたように見せかける可能性があります。(CVE-2010-2751)

Firefox が特定の無効な文字を表示する方法で、欠陥が見つかりました。悪意ある Web ページがこの欠陥を利用して、特定の文字列のサニタイズ方法をバイパスして、ユーザに悪意のある情報を表示する可能性があります。(CVE-2010-1210)

これらの欠陥の技術的な詳細については、Firefox 3.6.7 向けの Mozilla セキュリティアドバイザリを参照してください。Mozilla アドバイザリへのリンクは、このエラータの「参照」セクションにあります。

Firefox の全ユーザーは、Firefox バージョン 3.6.7 が含まれるこれらの更新済みパッケージへアップグレードし、これらの問題を修正する必要があります。更新をインストールした後、変更した内容を反映させるには Firefox を再起動する必要があります。

ソリューション

影響を受ける firefox パッケージを更新してください。

関連情報

http://www.nessus.org/u?1f115d85

http://www.nessus.org/u?938ae3fb

http://www.nessus.org/u?5bb95f40

http://www.nessus.org/u?47cf09c4

プラグインの詳細

深刻度: High

ID: 47806

ファイル名: centos_RHSA-2010-0547.nasl

バージョン: 1.19

タイプ: local

エージェント: unix

公開日: 2010/7/23

更新日: 2021/1/4

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 9.3

Temporal Score: 7.3

ベクトル: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

現状ベクトル: CVSS2#E:POC/RL:OF/RC:C

脆弱性情報

CPE: cpe:2.3:o:centos:centos:5:*:*:*:*:*:*:*, cpe:2.3:o:centos:centos:4:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:firefox:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:xulrunner:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:xulrunner-devel:*:*:*:*:*:*:*

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2010/8/6

脆弱性公開日: 2010/2/18

参照情報

CVE: CVE-2010-1211, CVE-2010-1214, CVE-2010-2753, CVE-2010-2754, CVE-2010-1205, CVE-2010-0654, CVE-2010-1206, CVE-2010-1207, CVE-2010-1208, CVE-2010-1209, CVE-2010-1210, CVE-2010-1212, CVE-2010-1213, CVE-2010-1215, CVE-2010-2751, CVE-2010-2752, CVE-2010-2760

BID: 41824, 41174, 41055

CWE: 94

RHSA: 2010:0547