Mandriva Linux セキュリティアドバイザリ:wireshark(MDVSA-2010:242)

high Nessus プラグイン ID 50827

言語:

概要

リモート Mandriva Linux ホストには、1 つ以上のセキュリティ更新がありません。

説明

このアドバイザリは、wireshark を最新バージョン(1.2.13)に更新し、 1 つのセキュリティの問題を解決します。

1.2.0 から 1.2.12 まで、および 1.4.0 から 1.4.1 までの Wireshark において、LDSS ディセクタでの dissect_ldss_transfer 関数(epan/dissectors/packet-ldss.c)におけるヒープベースのバッファオーバーフローにより、リモートの攻撃者は、メモリ破損を誘発する長いダイジェスト行がある LDSS パケットを通じて、サービス拒否(クラッシュ)を引き起こし、任意のコードを実行する可能性があります(CVE-2010-4300)。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

http://www.wireshark.org/docs/relnotes/wireshark-1.2.13.html

https://www.wireshark.org/security/wnpa-sec-2010-14.html

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=5318

プラグインの詳細

深刻度: High

ID: 50827

ファイル名: mandriva_MDVSA-2010-242.nasl

バージョン: 1.13

タイプ: local

公開日: 2010/11/29

更新日: 2021/1/6

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

脆弱性情報

CPE: p-cpe:/a:mandriva:linux:dumpcap, p-cpe:/a:mandriva:linux:lib64wireshark-devel, p-cpe:/a:mandriva:linux:lib64wireshark0, p-cpe:/a:mandriva:linux:libwireshark-devel, p-cpe:/a:mandriva:linux:libwireshark0, p-cpe:/a:mandriva:linux:rawshark, p-cpe:/a:mandriva:linux:tshark, p-cpe:/a:mandriva:linux:wireshark, p-cpe:/a:mandriva:linux:wireshark-tools, cpe:/o:mandriva:linux:2010.0, cpe:/o:mandriva:linux:2010.1

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2010/11/28

参照情報

CVE: CVE-2010-4300

BID: 44987

MDVSA: 2010:242