Debian DSA-2210-1:tiff - 複数の脆弱性

high Nessus プラグイン ID 53260
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Debian ホストに、セキュリティ更新がありません。

説明

TIFF 操作および変換ライブラリに複数の脆弱性が発見されました:

- CVE-2011-0191 バッファオーバーフローにより、JPEG エンコードされ、細工された TIFF イメージを介した任意のコード実行、あるいはサービス拒否が引き起こされる可能性があります。この問題は Debian 5.0 Lenny パッケージのみに影響します。

- CVE-2011-0192 バッファオーバーフローにより、CCITT グループ 4 エンコーディングを使用して圧縮され、細工された TIFF Internet Fax 画像ファイルを介した任意のコード実行、あるいはサービス拒否が引き起こされる可能性があります。

- CVE-2011-1167 thunder(別名 ThunderScan)デコーダーにおけるヒープベースのバッファオーバーフローにより、予定外の BitsPerSample の値が存在する TIFF ファイルを介して任意のコードの実行が引き起こされる可能性があります。

ソリューション

tiff パッケージをアップグレードしてください。

旧安定版(oldstable)ディストリビューション(lenny)では、これらの問題はバージョン 3.8.2-11.4 で修正されました。

安定版(stable)ディストリビューション(squeeze)では、これらの問題はバージョン 3.9.4-5+squeeze1 で修正されています。

関連情報

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=619614

https://security-tracker.debian.org/tracker/CVE-2011-0191

https://security-tracker.debian.org/tracker/CVE-2011-0192

https://security-tracker.debian.org/tracker/CVE-2011-1167

https://packages.debian.org/source/squeeze/tiff

https://www.debian.org/security/2011/dsa-2210

プラグインの詳細

深刻度: High

ID: 53260

ファイル名: debian_DSA-2210.nasl

バージョン: 1.11

タイプ: local

エージェント: unix

公開日: 2011/4/4

更新日: 2021/1/4

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 9.3

Temporal Score: 8.1

ベクトル: AV:N/AC:M/Au:N/C:C/I:C/A:C

現状ベクトル: E:ND/RL:OF/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:tiff, cpe:/o:debian:debian_linux:5.0, cpe:/o:debian:debian_linux:6.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2011/4/3

参照情報

CVE: CVE-2011-0191, CVE-2011-0192, CVE-2011-1167

BID: 46657, 46658, 46951

DSA: 2210