CentOS 4 / 5:netpbm(CESA-2011: 1811)

high Nessus プラグイン ID 57140
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのCentOSホストに1つ以上のセキュリティ更新プログラムが欠落しています。

説明

3 つのセキュリティの問題を修正する更新済みの netpbm パッケージが、 Red Hat Enterprise Linux 4 と 5 で現在利用可能です。

Red Hatセキュリティレスポンスチームは、この更新がセキュリティに及ぼす影響を重要度高として評価しています。詳細な重要度の評価を提供するCommon Vulnerability Scoring System(CVSS)のベーススコアは、「参照」セクションのCVEリンクから脆弱性ごとに確認できます。

netpbm パッケージには、.pbm(Portable Bit Map)、.pgm(Portable Gray Map)、.pnm(Portable Any Map)、.ppm(Portable Pixel Map)など、さまざまなグラフィックファイルフォーマットを処理するプログラムをサポートする関数ライブラリが含まれます。

埋め込み式 JasPer ライブラリで 2 つのヒープベースのバッファオーバーフロー欠陥が見つかりました。このライブラリは、jpeg2ktopam ツールと pamtojpeg2k ツールで JPEG 2000 画像圧縮規格のパート 1 のサポートを提供するために使用されます。
攻撃者が、悪意ある JPEG 2000 圧縮イメージファイルを作成することにより、 jpeg2ktopam をクラッシュさせたり、jpeg2ktopam を実行しているユーザーの権限で任意のコードを実行したりする可能性があります。
この欠陥はpamtojpeg2kに影響を与えません。(CVE-2011-4516、CVE-2011-4517)

xpmtoppm ツールが X PixMap(XPM)イメージファイルを処理する方法で、スタックベースのバッファオーバーフローの欠陥が見つかりました。攻撃者が、悪意あるXPMファイルを作成することにより、xpmtoppmをクラッシュさせたり、xpmtoppmを実行しているユーザーの権限で任意のコードを実行したりする可能性があります。(CVE-2009-4274)

Red Hat は、CVE-2011-4516 の問題と CVE-2011-4517 の問題を報告してくれた CERT Coordination Center の Jonathan Foote 氏に感謝の意を表します。

netpbm の全ユーザーは、バックポートされたパッチが含まれているこれらの更新済みパッケージへアップグレードし、これらの問題を修正することが推奨されます。

ソリューション

影響を受ける netpbm パッケージを更新してください。

関連情報

http://www.nessus.org/u?5f19815f

http://www.nessus.org/u?5dfe54de

http://www.nessus.org/u?75088498

http://www.nessus.org/u?81a9fe4f

プラグインの詳細

深刻度: High

ID: 57140

ファイル名: centos_RHSA-2011-1811.nasl

バージョン: 1.21

タイプ: local

エージェント: unix

公開日: 2011/12/13

更新日: 2021/1/4

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: High

スコア: 8.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:H/RL:OF/RC:C

脆弱性情報

CPE: p-cpe:/a:centos:centos:netpbm, p-cpe:/a:centos:centos:netpbm-devel, p-cpe:/a:centos:centos:netpbm-progs, cpe:/o:centos:centos:4, cpe:/o:centos:centos:5

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2011/12/12

脆弱性公開日: 2010/2/12

参照情報

CVE: CVE-2009-4274, CVE-2011-4516, CVE-2011-4517

BID: 38164, 50992

RHSA: 2011:1811

CWE: 119