CentOS 5:tomcat5(CESA-2011: 1845)

medium Nessus プラグイン ID 57354

概要

リモートのCentOSホストに1つ以上のセキュリティ更新プログラムが欠落しています。

説明

複数のセキュリティ問題を解決する更新済みの tomcat5 パッケージが、 Red Hat Enterprise Linux 5 で現在利用可能です。

Red Hatセキュリティレスポンスチームは、この更新がセキュリティに及ぼす影響を重要度中として評価しています。詳細な重要度の評価を提供するCommon Vulnerability Scoring System(CVSS)のベーススコアは、「参照」セクションのCVEリンクから脆弱性ごとに確認できます。

Apache Tomcatは、JavaサーブレットとJavaServer Pages(JSP)技術のサーブレットコンテナです。

Web アプリケーションが Tomcat ホストの作業ディレクトリの位置を変更できることが判明しました。Tomcat に展開されている Web アプリケーションがこのディレクトリへの読み取りおよび書き込みのアクセスを行えるようになると、悪意ある Web アプリケーションがこの欠陥を利用して、 Tomcat を騙して、ファイルシステム上の任意のディレクトリへの読み取りおよび書き込みのアクセスを行えるようにする可能性があります。
(CVE-2010-3718)

Apache Tomcat の Web アプリケーションを管理する Manager アプリケーションで、クロスサイトスクリプティング(XSS)の欠陥が見つかりました。悪意あるWebアプリケーションがこの欠陥を利用して、XSS攻撃を実行し、ManagerアプリケーションのWebページにログインして表示している被害者の権限で、任意のWebスクリプト実行を行う可能性があります。(CVE-2011-0013)

Tomcat が HTTP DIGEST 認証を処理する方法で、複数の欠陥が見つかりました。この欠陥はTomcat HTTP DIGEST認証実装を弱体化し、リモートの攻撃者によるセッションリプレイ攻撃を可能にするなど、いくつかのHTTP BASIC認証の弱点に陥りやすくします。(CVE-2011-1184)

Tomcat MemoryUserDatabase で欠陥が見つりました。JMX クライアントを用いて新規ユーザーを作成する際にランタイム例外が発生した場合、ユーザーのパスワードが Tomcat ログファイルに記録されます。注:デフォルトでは、管理者のみがこのようなログファイルにアクセスできます。(CVE-2011-2204)

Tomcat のユーザーは、バックポートされたパッチが含まれるこれらの更新済みパッケージへアップグレードし、この問題を修正する必要があります。この更新を有効にするには、Tomcat を再起動する必要があります。

ソリューション

影響を受けるtomcat5パッケージを更新してください。

関連情報

http://www.nessus.org/u?b9373df8

http://www.nessus.org/u?d801a1f1

プラグインの詳細

深刻度: Medium

ID: 57354

ファイル名: centos_RHSA-2011-1845.nasl

バージョン: 1.15

タイプ: local

エージェント: unix

公開日: 2011/12/21

更新日: 2021/1/4

サポートされているセンサー: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure

リスク情報

VPR

リスクファクター: Medium

スコア: 4

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:P/I:N/A:N

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: p-cpe:/a:centos:centos:tomcat5, p-cpe:/a:centos:centos:tomcat5-admin-webapps, p-cpe:/a:centos:centos:tomcat5-common-lib, p-cpe:/a:centos:centos:tomcat5-jasper, p-cpe:/a:centos:centos:tomcat5-jasper-javadoc, p-cpe:/a:centos:centos:tomcat5-jsp-2.0-api, p-cpe:/a:centos:centos:tomcat5-jsp-2.0-api-javadoc, p-cpe:/a:centos:centos:tomcat5-server-lib, p-cpe:/a:centos:centos:tomcat5-servlet-2.4-api, p-cpe:/a:centos:centos:tomcat5-servlet-2.4-api-javadoc, p-cpe:/a:centos:centos:tomcat5-webapps, cpe:/o:centos:centos:5

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2011/12/20

脆弱性公開日: 2011/2/10

参照情報

CVE: CVE-2010-3718, CVE-2011-0013, CVE-2011-1184, CVE-2011-2204, CVE-2011-5062, CVE-2011-5063, CVE-2011-5064

BID: 46174, 46177, 48456, 49762

RHSA: 2011:1845