Debian DSA-2408-1:php5 - いくつかの脆弱性

high Nessus プラグイン ID 57925
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Debian ホストに、セキュリティ更新がありません。

説明

Web スクリプト言語である PHP で、いくつかの脆弱性が発見されました。Common Vulnerabilities and Exposures プロジェクトでは、次の問題を特定しています:

- CVE-2011-1072 PEAR インストーラーにおける安全でない一時ファイルの処理が、サービス拒否につながることが判明しました。

- CVE-2011-4153 Maksymilian Arciemowicz 氏は、zend_strndup() 関数の NULL ポインターデリファレンスがサービス拒否につながることを発見しました。

- CVE-2012-0781 Maksymilian Arciemowicz 氏は、tidy_diagnose() 関数の NULL ポインターデリファレンスがサービス拒否につながることを発見しました。

- CVE-2012-0788 PDORow オブジェクト処理のチェックの漏れが、サービス拒否につながることが判明しました。

- CVE-2012-0831 magic_quotes_gpc 設定はリモートで無効化が可能であることが判明しました。

この更新は PHP のバグに対処します。これらは Debian ではセキュリティ問題として扱われていませんが(README.Debian.security を参照)、修正がなされています:CVE-2010-4697、CVE-2011-1092、CVE-2011-1148、CVE-2011-1464、CVE-2011-1467、CVE-2011-1468、CVE-2011-1469、CVE-2011-1470、CVE-2011-1657、CVE-2011-3182、CVE-2011-3267

ソリューション

php5 パッケージをアップグレードしてください。

安定版(stable)ディストリビューション(squeeze)では、この問題はバージョン 5.3.3-7+squeeze8 で修正されています。

関連情報

https://security-tracker.debian.org/tracker/CVE-2011-1072

https://security-tracker.debian.org/tracker/CVE-2011-4153

https://security-tracker.debian.org/tracker/CVE-2012-0781

https://security-tracker.debian.org/tracker/CVE-2012-0788

https://security-tracker.debian.org/tracker/CVE-2012-0831

https://security-tracker.debian.org/tracker/CVE-2010-4697

https://security-tracker.debian.org/tracker/CVE-2011-1092

https://security-tracker.debian.org/tracker/CVE-2011-1148

https://security-tracker.debian.org/tracker/CVE-2011-1464

https://security-tracker.debian.org/tracker/CVE-2011-1467

https://security-tracker.debian.org/tracker/CVE-2011-1468

https://security-tracker.debian.org/tracker/CVE-2011-1469

https://security-tracker.debian.org/tracker/CVE-2011-1470

https://security-tracker.debian.org/tracker/CVE-2011-1657

https://security-tracker.debian.org/tracker/CVE-2011-3182

https://security-tracker.debian.org/tracker/CVE-2011-3267

https://packages.debian.org/source/squeeze/php5

https://www.debian.org/security/2012/dsa-2408

プラグインの詳細

深刻度: High

ID: 57925

ファイル名: debian_DSA-2408.nasl

バージョン: 1.15

タイプ: local

エージェント: unix

公開日: 2012/2/14

更新日: 2021/1/11

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:H/RL:OF/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:php5, cpe:/o:debian:debian_linux:6.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2012/2/13

参照情報

CVE: CVE-2010-4697, CVE-2011-1072, CVE-2011-1092, CVE-2011-1148, CVE-2011-1464, CVE-2011-1467, CVE-2011-1468, CVE-2011-1469, CVE-2011-1470, CVE-2011-1657, CVE-2011-3182, CVE-2011-3267, CVE-2011-4153, CVE-2012-0781, CVE-2012-0788, CVE-2012-0831

BID: 46605, 51417, 51952, 51954

DSA: 2408