Debian DSA-2410-1:libpng - 整数オーバーフロー

high Nessus プラグイン ID 57964
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Debian ホストに、セキュリティ更新がありません。

説明

Jueri Aedla 氏は、libpng PNG ライブラリにおける整数オーバーフローを発見しました。これにより、無効な形式の画像が処理された場合、任意のコードの実行が引き起こされる可能性があります。

ソリューション

libpng パッケージをアップグレードしてください。

安定版(stable)ディストリビューション(squeeze)では、この問題はバージョン 1.2.44-1+squeeze2 で修正されています。

関連情報

https://packages.debian.org/source/squeeze/libpng

https://www.debian.org/security/2012/dsa-2410

プラグインの詳細

深刻度: High

ID: 57964

ファイル名: debian_DSA-2410.nasl

バージョン: 1.8

タイプ: local

エージェント: unix

公開日: 2012/2/16

更新日: 2021/1/11

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 5.8

CVSS v2

リスクファクター: High

Base Score: 7.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:libpng, cpe:/o:debian:debian_linux:6.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

パッチ公開日: 2012/2/15

参照情報

CVE: CVE-2011-3026

DSA: 2410