Debian DSA-2465-1:php5 - いくつかの脆弱性

high Nessus プラグイン ID 59059

概要

リモート Debian ホストに、セキュリティ更新がありません。

説明

De Eindbazen 氏は、PHP が、mod_cgi とともに実行されるとき、クエリ文字列をコマンドラインパラメーターとして解釈し、任意のコード実行をできることを発見しました。

さらに、この更新により、$_FILES インデックスの破損が発生するアップロード名の不十分な検証が修正されます。

ソリューション

php5 パッケージをアップグレードしてください。

安定版(stable)ディストリビューション(squeeze)では、この問題はバージョン 5.3.3-7+squeeze9 で修正されています。

関連情報

https://packages.debian.org/source/squeeze/php5

https://www.debian.org/security/2012/dsa-2465

プラグインの詳細

深刻度: High

ID: 59059

ファイル名: debian_DSA-2465.nasl

バージョン: 1.19

タイプ: local

エージェント: unix

公開日: 2012/5/10

更新日: 2022/3/28

サポートされているセンサー: Frictionless Assessment Agent, Nessus Agent

リスク情報

VPR

リスクファクター: High

スコア: 8.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:H/RL:OF/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:php5, cpe:/o:debian:debian_linux:6.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2012/5/9

CISAの既知の悪用日: 2022/4/15

エクスプロイト可能

CANVAS (CANVAS)

Core Impact

Metasploit (PHP CGI Argument Injection)

参照情報

CVE: CVE-2012-1172, CVE-2012-1823, CVE-2012-2311

BID: 53388, 53403

DSA: 2465