CentOS 6:glibc (CESA-2012:1208)

medium Nessus プラグイン ID 61720
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート CentOS ホストに1つ以上のセキュリティ更新がありません。

説明

複数のセキュリティ問題を修正する更新済みの glibc パッケージが、 Red Hat Enterprise Linux 6 で現在利用可能です。

Red Hat セキュリティレスポンスチームは、この更新のセキュリティ上の影響は中程度であると評価しています。詳細な重要度評価を示す Common Vulnerability Scoring System(CVSS)ベーススコアは「参照」セクションの CVE リンクで入手できます。

glibc パッケージは、システムの複数プログラムで使用されている標準 C ライブラリと標準数学ライブラリを提供します。これらのライブラリがないと、 Linux システムは適切に機能しません。

文字列を数値表現に変換するための glibc の関数(strtod()、strtof()、および strtold())に、スタックベースのバッファオーバーフローにつながる、複数の整数オーバーフローの欠陥が見つかりました。アプリケーションが攻撃者の入力をコントロールする関数を使用した場合、これは、アプリケーションがクラッシュしたり、任意のコードが実行される原因になる可能性があります。(CVE-2012-3480)

glibc の全ユーザーは、バックポートされたパッチが含まれるこれらの更新済みパッケージへアップグレードし、これらの問題を修正することが推奨されます。

ソリューション

影響を受ける glibc パッケージを更新してください。

関連情報

http://www.nessus.org/u?9be4e5d9

プラグインの詳細

深刻度: Medium

ID: 61720

ファイル名: centos_RHSA-2012-1208.nasl

バージョン: 1.13

タイプ: local

エージェント: unix

公開日: 2012/8/30

更新日: 2021/1/4

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2012-3480

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 4.6

Temporal Score: 3.6

ベクトル: AV:L/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

脆弱性情報

CPE: p-cpe:/a:centos:centos:glibc, p-cpe:/a:centos:centos:glibc-common, p-cpe:/a:centos:centos:glibc-devel, p-cpe:/a:centos:centos:glibc-headers, p-cpe:/a:centos:centos:glibc-static, p-cpe:/a:centos:centos:glibc-utils, p-cpe:/a:centos:centos:nscd, cpe:/o:centos:centos:6

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2012/8/27

脆弱性公開日: 2012/8/25

参照情報

CVE: CVE-2012-3480

RHSA: 2012:1208