CentOS 5:mysql55-mysql(CESA-2014:0186)

high Nessus プラグイン ID 72592
New! Vulnerability Priority Rating (VPR)

Tenable では、すべての脆弱性に対して動的な VPR が計算されます。VPR は脆弱性の情報を、脅威インテリジェンスや機械学習アルゴリズムと組み合わせて、攻撃時に最も悪用される可能性の高い脆弱性を予測します。詳細は、 「VPR とは何で、CVSS とはどう違うのか」を参照してください。

VPR スコア : 5.9

概要

リモート CentOS ホストに1つ以上のセキュリティ更新がありません。

説明

いくつかのセキュリティの問題を修正する更新済みの mysql55-mysql パッケージが、 Red Hat Enterprise Linux 5 で現在利用可能です。

Red Hat セキュリティレスポンスチームは、この更新のセキュリティ上の影響は中程度であると評価しています。詳細な重要度の評価を提供する Common Vulnerability Scoring System (CVSS)のベーススコアが、「参照」セクションの CVE リンクの各脆弱性に対して利用可能です。

MySQL は、マルチユーザー、マルチスレッドの SQL データベースサーバーで、MySQL サーバーデーモン(mysqld)と多数のクライアントプログラムおよびライブラリで構成されています。

この更新により、 MySQL データベースサーバーにある複数の脆弱性が修正されます。この欠陥の詳細については、「参照」セクションに一覧されている Oracle Critical Patch Update アドバイザリページを参照してください。
(CVE-2013-5807、CVE-2013-5891、CVE-2014-0386、CVE-2014-0393、CVE-2014-0401、CVE-2014-0402、CVE-2014-0412、CVE-2014-0420、CVE-2014-0437、CVE-2013-3839、CVE-2013-5908)

MySQL コマンドラインクライアントツール(mysql)が、極端に長いバージョン文字列を処理する方法で、バッファオーバーフローの欠陥が見つかりました。ユーザーが、 mysql クライアントで悪意のある MySQL サーバーに接続した場合、サーバーが、この欠陥を利用して、mysql クライアントをクラッシュさせたり、 mysql クライアントを実行しているユーザーの権限で任意のコードを実行したりする可能性があります。
(CVE-2014-0001)

CVE-2014-0001 の問題は、Red Hat セキュリティレスポンスチームの Garth Mollett 氏により発見されました。

これらの更新済みパッケージは、MySQL をバージョン 5.5.36 にアップグレードします。変更内容の完全なリストについては、「参照」セクションにリストされている MySQL のリリースノートを参照してください。

MySQL のすべてのユーザーは、これらの更新パッケージにアップグレードし、これらの問題を修正する必要があります。この更新のインストール後、 MySQL サーバーデーモン(mysqld)が自動的に再起動します。

ソリューション

影響を受ける mysql55-mysql パッケージを更新してください。

関連情報

http://www.nessus.org/u?871456a0

プラグインの詳細

深刻度: High

ID: 72592

ファイル名: centos_RHSA-2014-0186.nasl

バージョン: 1.9

タイプ: local

エージェント: unix

公開日: 2014/2/20

更新日: 2021/1/4

依存関係: ssh_get_info.nasl

リスク情報

リスクファクター: High

VPR スコア: 5.9

CVSS スコアのソース: CVE-2014-0001

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

脆弱性の情報

CPE: p-cpe:/a:centos:centos:mysql55-mysql, p-cpe:/a:centos:centos:mysql55-mysql-bench, p-cpe:/a:centos:centos:mysql55-mysql-devel, p-cpe:/a:centos:centos:mysql55-mysql-libs, p-cpe:/a:centos:centos:mysql55-mysql-server, p-cpe:/a:centos:centos:mysql55-mysql-test, cpe:/o:centos:centos:5

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2014/2/19

脆弱性公開日: 2013/10/16

参照情報

CVE: CVE-2013-3839, CVE-2013-5807, CVE-2013-5891, CVE-2013-5908, CVE-2014-0001, CVE-2014-0386, CVE-2014-0393, CVE-2014-0401, CVE-2014-0402, CVE-2014-0412, CVE-2014-0420, CVE-2014-0437

BID: 63105, 63109, 64849, 64877, 64880, 64888, 64891, 64896, 64898, 64904, 64908, 65298

RHSA: 2014:0186