CentOS 6:qemu-kvm(CESA-2014:0420)

high Nessus プラグイン ID 73656
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート CentOS ホストに1つ以上のセキュリティ更新がありません。

説明

複数のセキュリティの問題を修正する更新された qemu-kvm パッケージが、 Red Hat Enterprise Linux 6 で現在入手できます。

Red Hat セキュリティレスポンスチームは、この更新のセキュリティ上の影響は中程度であると評価しています。詳細な重要度の評価を提供する Common Vulnerability Scoring System (CVSS)のベーススコアが、「参照」セクションの CVE リンクの各脆弱性に対して利用可能です。

KVM(カーネルベース仮想マシン)は、AMD64 および Intel 64 システムの、Linux 向けの完全な仮想化ソリューションです。qemu-kvm パッケージは、 KVM を使用している仮想マシンを実行する場合に、ユーザー空間コンポーネントを実現します。

いくつかの QEMU ブロックドライバーで、複数の整数オーバーフロー、入力検証、論理エラー、およびバッファオーバーフローの欠陥が発見されました。あるゲストがロードしたディスクイメージファイルを変更できる攻撃者は、これらの欠陥を悪用して、そのゲストをクラッシュさせることがあります。あるいは、ホスト上の QEMU プロセスメモリを破損させることがあり、QEMU プロセスの権限で、ホストで任意のコードを実行する可能性があります。(CVE-2014-0143、CVE-2014-0144、CVE-2014-0145、 CVE-2014-0147)

QEMU の virtio_net_handle_mac() 関数によってゲストリクエストを処理して Mac アドレスのテーブルを更新する方法で、バッファオーバーフロー欠陥が見つかりました。権限のあるゲストユーザーは、この欠陥を悪用して、ホスト上の QEMU プロセスメモリを破損させることがあります。これにより、QEMU プロセスの権限で、ホストで任意のコードが実行される可能性があります。(CVE-2014-0150)

QEMU のパラレルブロックドライバーの seek_to_sector() 関数に、ゼロ除算欠陥が見つかりました。あるゲストがロードしたディスクイメージファイルを変更できる攻撃者は、この欠陥を悪用して、そのゲストをクラッシュさせることがあります。
(CVE-2014-0142)

QEMU の QCOW2 ブロックドライバーに NULL ポインターデリファレンス欠陥が見つかりました。あるゲストがロードしたディスクイメージファイルを変更できる攻撃者は、この欠陥を悪用して、そのゲストをクラッシュさせることがあります。(CVE-2014-0146)

Hyper-V VHDX イメージのブロックドライバーによって、バインドチェックの欠落のために BAT(Block Allocation Table)エントリが正しく計算されないことが、見つかりました。あるゲストがロードしたディスクイメージファイルを変更できる攻撃者は、この欠陥を悪用して、そのゲストをクラッシュさせることがあります。
(CVE-2014-0148)

CVE-2014-0143 の問題は Red Hat の Kevin Wolf 氏と Stefan Hajnoczi 氏により、CVE-2014-0144 の問題は Red Hat の Fam Zheng 氏、Jeff Cody 氏、Kevin Wolf 氏、および Stefan Hajnoczi 氏により、CVE-2014-0145 の問題は Red Hat の Stefan Hajnoczi 氏により、CVE-2014-0150 の問題は Red Hat の Michael S. Tsirkin 氏により、CVE-2014-0142、CVE-2014-0146、および CVE-2014-0147 の問題は Red Hat の Kevin Wolf 氏により、CVE-2014-0148 の問題は Red Hat の Jeff Cody 氏により発見されました。

qemu-kvm のすべてのユーザーには、更新されたこれらのパッケージにアップグレードすることが推奨されます。これらのパッケージには、これらの問題を修正するバックポートされたパッチが収納されています。この更新をインストールした後、実行中の仮想マシンをすべてシャットダウンします。すべての仮想マシンをシャットダウンしたら、この更新を有効にするために、再起動します。

ソリューション

影響を受ける qemu-kvm パッケージを更新してください。

関連情報

http://www.nessus.org/u?62e51ef1

プラグインの詳細

深刻度: High

ID: 73656

ファイル名: centos_RHSA-2014-0420.nasl

バージョン: 1.14

タイプ: local

エージェント: unix

公開日: 2014/4/23

更新日: 2021/1/4

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2014-0150

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 4.9

Temporal Score: 3.6

ベクトル: AV:A/AC:M/Au:S/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:centos:centos:qemu-guest-agent, p-cpe:/a:centos:centos:qemu-img, p-cpe:/a:centos:centos:qemu-kvm, p-cpe:/a:centos:centos:qemu-kvm-tools, cpe:/o:centos:centos:6

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2014/4/22

脆弱性公開日: 2014/4/18

参照情報

CVE: CVE-2014-0142, CVE-2014-0143, CVE-2014-0144, CVE-2014-0145, CVE-2014-0146, CVE-2014-0147, CVE-2014-0148, CVE-2014-0150

BID: 66464, 66472, 66480, 66481, 66483, 66484, 66486, 66821

RHSA: 2014:0420