CentOS 5/6:samba/samba3x(CESA-2014:0866)

low Nessus プラグイン ID 76431

概要

リモート CentOS ホストに1つ以上のセキュリティ更新がありません。

説明

2つのセキュリティ問題を修正する更新済みの samba3x と samba パッケージが、 Red Hat Enterprise Linux 5 および 6 でそれぞれ現在利用可能です。

Red Hat セキュリティレスポンスチームは、この更新のセキュリティ上の影響は中程度であると評価しています。詳細な重要度の評価を提供する Common Vulnerability Scoring System (CVSS)のベーススコアが、「参照」セクションの CVE リンクの各脆弱性に対して利用可能です。

Samba は Server Message Block (SMB)プロトコルまたは Common Internet File System(CIFS)プロトコルのオープンソース実装であり、これを使用すると PC 互換機がファイル、プリンター、その他の情報を共有できるようになります。

NetBIOS メッセージブロックデーモンの nmbd の sys_recvfile() 関数が非ブロックソケットを処理していた方法で、サービス拒否の欠陥が見つかりました。攻撃者は特別に細工されたパケットを送信することができます。これが処理されると、nmbd が無限ループに陥り、膨大な CPU 時間を消費する恐れがあります。(CVE-2014-0244)

Samba ファイルサーバーデーモンの smbd が、ディスク上に保存された特定のファイルを適切に処理しておらず、そのファイル名の有効な Unicode 文字を使用していたことが判明しました。攻撃者はそのようなファイルの読み込みを意図した認証済みの非 Unicode リクエストを送信することができ、smbd をクラッシュさせることがあります。(CVE-2014-3493)

Red Hat は、CVE-2014-0244 を報告してくれた FIREWALL-SERVICES SARL の Daniel Berteaud 氏、CVE-2014-3493 を報告してくれた Samba プロジェクトに感謝の意を表します。Samba プロジェクトは、CVE-2014-3493 の最初の報告者として Simon Arlott 氏を認識しています。

Samba の全ユーザーは、バックポートされたパッチが含まれるこれらの更新済みパッケージへアップグレードし、これらの問題を修正することが推奨されます。この更新をインストールすると、smb サービスが自動的に再起動されます。

ソリューション

影響を受ける samba および/または samba3x パッケージを更新してください。

関連情報

http://www.nessus.org/u?4655ca2b

http://www.nessus.org/u?0ae942e6

プラグインの詳細

深刻度: Low

ID: 76431

ファイル名: centos_RHSA-2014-0866.nasl

バージョン: 1.8

タイプ: local

エージェント: unix

公開日: 2014/7/10

更新日: 2021/1/4

サポートされているセンサー: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure

リスク情報

CVSS スコアのソース: CVE-2014-0244

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Low

Base Score: 3.3

Temporal Score: 2.9

ベクトル: AV:A/AC:L/Au:N/C:N/I:N/A:P

現状ベクトル: E:ND/RL:OF/RC:C

脆弱性情報

CPE: p-cpe:/a:centos:centos:libsmbclient, p-cpe:/a:centos:centos:libsmbclient-devel, p-cpe:/a:centos:centos:samba, p-cpe:/a:centos:centos:samba-client, p-cpe:/a:centos:centos:samba-common, p-cpe:/a:centos:centos:samba-doc, p-cpe:/a:centos:centos:samba-domainjoin-gui, p-cpe:/a:centos:centos:samba-swat, p-cpe:/a:centos:centos:samba-winbind, p-cpe:/a:centos:centos:samba-winbind-clients, p-cpe:/a:centos:centos:samba-winbind-devel, p-cpe:/a:centos:centos:samba-winbind-krb5-locator, p-cpe:/a:centos:centos:samba3x, p-cpe:/a:centos:centos:samba3x-client, p-cpe:/a:centos:centos:samba3x-common, p-cpe:/a:centos:centos:samba3x-doc, p-cpe:/a:centos:centos:samba3x-domainjoin-gui, p-cpe:/a:centos:centos:samba3x-swat, p-cpe:/a:centos:centos:samba3x-winbind, p-cpe:/a:centos:centos:samba3x-winbind-devel, cpe:/o:centos:centos:5, cpe:/o:centos:centos:6

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2014/7/9

脆弱性公開日: 2014/6/23

参照情報

CVE: CVE-2014-0244, CVE-2014-3493

BID: 68148, 68150

RHSA: 2014:0866