CentOS 5:php53(CESA-2014:1768)

high Nessus プラグイン ID 78783

概要

リモート CentOS ホストに1つ以上のセキュリティ更新がありません。

説明

複数のセキュリティ問題を解決する更新済みの php53 パッケージが、 Red Hat Enterprise Linux 5 で現在利用可能です。

Red Hat 製品セキュリティは、この更新がセキュリティに及ぼす影響を重要度高として評価しています。詳細な重要度の評価を提供する Common Vulnerability Scoring System (CVSS)のベーススコアが、「参照」セクションの CVE リンクの各脆弱性に対して利用可能です。

PHP は、Apache HTTP Server で一般的に使用される、 HTML を組み込んだスクリプト言語です。

Exif エクステンションにおいて、バッファオーバーフローの欠陥が検出されました。特別に細工された JPEG または TIFF ファイルは、exif_thumbnail() 関数を使用している PHP アプリケーションをクラッシュさせたり、PHP アプリケーションを実行しているユーザーの権限で任意のコードを実行する可能性があります。
(CVE-2014-3670)

カスタムオブジェクトがシリアル化解除される方法で、整数オーバーフローの欠陥が見つかりました。unserialize() 関数によって処理される、特別に細工された入力が、 PHP アプリケーションをクラッシュさせる可能性があります。(CVE-2014-3669)

File Information(fileinfo)拡張が Executable および Linkable Format(ELF)ファイルを解析する方法に、範囲外読み取りの欠陥が検出されました。リモートの攻撃者がこの欠陥を利用して、特別に細工された ELF ファイルで、 fileinfo を使用する PHP アプリケーションをクラッシュさせる可能性があります。
(CVE-2014-3710)

xmlrpc エクステンションが ISO 8601 形式の日付を解析する方法において、領域外読み込みの欠陥が検出されました。特別に細工された XML-RPC リクエストまたは応答が、PHP アプリケーションのクラッシュを引き起こす可能性があります。
(CVE-2014-3668)

CVE-2014-3710 の問題は、Red Hat 製品セキュリティの Francisco Alonso 氏により発見されました。

php53 の全ユーザーは、バックポートされたパッチが含まれるこれらの更新済みパッケージへアップグレードし、これらの問題を修正することが推奨されます。更新したパッケージをインストールした後、更新を有効にするために httpd デーモンを再起動する必要があります。

ソリューション

影響を受ける php53 パッケージを更新してください。

関連情報

http://www.nessus.org/u?ec8306ba

プラグインの詳細

深刻度: High

ID: 78783

ファイル名: centos_RHSA-2014-1768.nasl

バージョン: 1.11

タイプ: local

エージェント: unix

公開日: 2014/11/3

更新日: 2021/1/4

サポートされているセンサー: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2014-3669

脆弱性情報

CPE: p-cpe:/a:centos:centos:php53, p-cpe:/a:centos:centos:php53-bcmath, p-cpe:/a:centos:centos:php53-cli, p-cpe:/a:centos:centos:php53-common, p-cpe:/a:centos:centos:php53-dba, p-cpe:/a:centos:centos:php53-devel, p-cpe:/a:centos:centos:php53-gd, p-cpe:/a:centos:centos:php53-imap, p-cpe:/a:centos:centos:php53-intl, p-cpe:/a:centos:centos:php53-ldap, p-cpe:/a:centos:centos:php53-mbstring, p-cpe:/a:centos:centos:php53-mysql, p-cpe:/a:centos:centos:php53-odbc, p-cpe:/a:centos:centos:php53-pdo, p-cpe:/a:centos:centos:php53-pgsql, p-cpe:/a:centos:centos:php53-process, p-cpe:/a:centos:centos:php53-pspell, p-cpe:/a:centos:centos:php53-snmp, p-cpe:/a:centos:centos:php53-soap, p-cpe:/a:centos:centos:php53-xml, p-cpe:/a:centos:centos:php53-xmlrpc, cpe:/o:centos:centos:5

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2014/10/31

脆弱性公開日: 2014/10/29

参照情報

CVE: CVE-2014-3668, CVE-2014-3669, CVE-2014-3670, CVE-2014-3710

BID: 70611, 70665, 70666, 70807

RHSA: 2014:1768