Debian DSA-3064-1:php5 - セキュリティ更新

high Nessus プラグイン ID 78861
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Debian ホストに、セキュリティ更新がありません。

説明

Web アプリケーションの開発でよく使用される汎用スクリプト言語である PHP に、いくつかの脆弱性が見つかりました。Wheezy PHP パッケージについては、安定版(stable)5.4.x リリースに従うことが決定されています。結果として、この脆弱性は、新しい上流バージョン 5.4.34 に PHP をアップグレードすることで対処されています。この上流バージョンには、追加的なバグ修正、新機能、互換性のない変更が含まれています。詳細については、上流の変更ログを参照してください。

http://php.net/ChangeLog-5.php#5.4.34

ソリューション

php5 パッケージをアップグレードしてください。

安定版(stable)ディストリビューション(wheezy)に対して、これらの問題はバージョン 5.4.34-0+deb7u1 で修正されています。

関連情報

http://php.net/ChangeLog-5.php#5.4.34

https://packages.debian.org/source/wheezy/php5

https://www.debian.org/security/2014/dsa-3064

プラグインの詳細

深刻度: High

ID: 78861

ファイル名: debian_DSA-3064.nasl

バージョン: 1.15

タイプ: local

エージェント: unix

公開日: 2014/11/5

更新日: 2021/1/11

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:php5, cpe:/o:debian:debian_linux:7.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2014/11/4

参照情報

CVE: CVE-2013-7345, CVE-2014-3668, CVE-2014-3669, CVE-2014-3670

BID: 70611, 70665, 70666

DSA: 3064