CentOS 6:カーネル(CESA-2015:1081)

high Nessus プラグイン ID 84091
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート CentOS ホストに1つ以上のセキュリティ更新がありません。

説明

複数のセキュリティの問題といくつかのバグを修正し、さまざまな強化機能を追加したカーネルパッケージが、 Red Hat Enterprise Linux 6 で現在利用可能です。

Red Hat 製品セキュリティは、この更新がセキュリティに及ぼす影響を重要度高として評価しています。詳細な重要度の評価を提供する Common Vulnerability Scoring System (CVSS)のベーススコアが、「参照」セクションの CVE リンクの各脆弱性に対して利用可能です。

カーネルパッケージには Linux オペレーティングシステムのコアである Linux カーネルが含まれています。

* ベクトルパイプの読み書き機能性の Linux カーネルの実装が、アトミックアクセス操作に失敗した後で再試行する際に、すでに処理されている I/O ベクトルを考慮していないことが判明しました。このため、I/O ベクトル配列オーバーランによるメモリ破損が発生する可能性があります。権限のないローカルユーザーが、この欠陥を利用して、システムをクラッシュさせたり、システムの権限を昇格したりする可能性があります。(CVE-2015-1805、重要度高)

* Linux カーネルの Intel AES-NI 命令がフラグメント化されたパケットを処理していた RFC4106 GCM モードの復号化機能のバージョンを最適化する方法で、バッファオーバーフローの欠陥が見つかりました。リモートの攻撃者がこの欠陥を悪用し、アクティブな AES-GCM モードの IPsec セキュリティ関連付けがされた接続を通してシステムをクラッシュしたり、権限をエスカレーションしたりする恐れがあります。(CVE-2015-3331、重要度高)

* Linux カーネルがコンテキスト切り替え中に特定のセグメントレジスタとスレッドローカルストレージ(TLS)を変更する方法に、情報漏洩の欠陥が見つかりました。ローカルの権限のないユーザーが、この欠陥を悪用し、任意プロセスのユーザー空間の TLS ベースアドレスを漏洩させる可能性があります。
(CVE-2014-9419、重要度低)

* Linux カーネルの ISO ファイルシステムの実装が、Rock Ridge 拡張の継続エントリ(CE)のトラバーサルを正しく制限していないことが見つかりました。システムに物理的にアクセスできる攻撃者が、この欠陥を利用して、カーネルで無限ループを発生させる可能性があります。これによりサービス拒否が発生します。(CVE-2014-9420、重要度低)

* Linux カーネルの Virtual Dyanamic Shared Object(vDSO)がアドレスのランダム化を行っていた方法で、情報漏洩の欠陥が見つかりました。権限のないローカルユーザーが、この欠陥を利用して、ユーザー空間にカーネルメモリアドレスを漏洩する可能性があります。(CVE-2014-9585、重要度低)

Red Hat は、CVE-2014-9420 を報告してくれた Carl Henrik Lunde 氏に感謝の意を表します。CVE-2015-1805 の問題がセキュリティに与える影響は、Red Hat によって発見されました。

また、この更新では複数のバグが修正され、さまざまな拡張機能が追加されます。
これらの変更に関するドキュメントは、「参照」セクションにリンクされているテクニカルノートのドキュメントから参照できます。

カーネルの全ユーザーは、バックポートされたパッチが含まれるこれらの更新済みパッケージへアップグレードし、これらの問題を修正し、拡張機能を追加することが推奨されます。この更新を有効にするには、システムを再起動する必要があります。

ソリューション

影響を受けるカーネルパッケージを更新してください。

関連情報

http://www.nessus.org/u?1cf05d0f

プラグインの詳細

深刻度: High

ID: 84091

ファイル名: centos_RHSA-2015-1081.nasl

バージョン: 2.11

タイプ: local

エージェント: unix

公開日: 2015/6/11

更新日: 2021/1/4

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2015-3331

VPR

リスクファクター: Critical

スコア: 9.4

CVSS v2

リスクファクター: High

Base Score: 9.3

Temporal Score: 8.1

ベクトル: AV:N/AC:M/Au:N/C:C/I:C/A:C

現状ベクトル: E:H/RL:OF/RC:C

脆弱性情報

CPE: p-cpe:/a:centos:centos:kernel, p-cpe:/a:centos:centos:kernel-abi-whitelists, p-cpe:/a:centos:centos:kernel-debug, p-cpe:/a:centos:centos:kernel-debug-devel, p-cpe:/a:centos:centos:kernel-devel, p-cpe:/a:centos:centos:kernel-doc, p-cpe:/a:centos:centos:kernel-firmware, p-cpe:/a:centos:centos:kernel-headers, p-cpe:/a:centos:centos:perf, p-cpe:/a:centos:centos:python-perf, cpe:/o:centos:centos:6

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2015/6/10

脆弱性公開日: 2014/12/26

参照情報

CVE: CVE-2014-9419, CVE-2014-9420, CVE-2014-9585, CVE-2015-1805, CVE-2015-3331

BID: 71717, 71794, 71990, 74235, 74951

RHSA: 2015:1081