Debian DSA-3327-1:squid3 - セキュリティ更新

medium Nessus プラグイン ID 85184

概要

リモート Debian ホストに、セキュリティ更新がありません。

説明

Measurement Factory の Alex Rousskov 氏は、完全に機能する Web プロキシキャッシュである Squid3 が明確なプロキシトラフィックの cache_peer と操作を設定する時、CONNECT メソッドのピアレスポンスを正しく処理できないことを発見しました。これにより、リモートクライアントが、ゲートウェイプロキシを通してバックエンドプロキシへの制限の無いアクセス権を取得する可能性があります。

ソリューション

squid3 パッケージをアップグレードしてください。

旧安定版(oldstable)ディストリビューション(wheezy)では、この問題はバージョン 3.1.20-2.2+deb7u3 で修正されています。

安定版(stable)ディストリビューション(jessie)では、この問題はバージョン 3.4.8-6+deb8u1 で修正されています。

関連情報

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=793128

https://packages.debian.org/source/wheezy/squid3

https://packages.debian.org/source/jessie/squid3

https://www.debian.org/security/2015/dsa-3327

プラグインの詳細

深刻度: Medium

ID: 85184

ファイル名: debian_DSA-3327.nasl

バージョン: 2.5

タイプ: local

エージェント: unix

公開日: 2015/8/4

更新日: 2021/1/11

サポートされているセンサー: Frictionless Assessment Agent, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:squid3, cpe:/o:debian:debian_linux:7.0, cpe:/o:debian:debian_linux:8.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

パッチ公開日: 2015/8/3

参照情報

CVE: CVE-2015-5400

DSA: 3327