Debian DSA-3554-1:xen - セキュリティ更新

high Nessus プラグイン ID 90638
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモート Debian ホストに、セキュリティ更新がありません。

説明

複数の脆弱性が、Xen ハイパーバイザーに見つかりました。
Common Vulnerabilities and Exposures プロジェクトは次の問題を特定しています:

- CVE-2016-3158、CVE-2016-3159(XSA-172)SUSE の Jan Beulich 氏は、AMD64 プロセッサで実行中に、Xen がハードウェア FSW.ES ビットへの書き込みを適切に処理していないことを発見しました。悪意のあるドメインがこの欠陥を利用して、非常に低レートで、別のドメインに関するアドレス空間使用とタイミングの情報を入手する可能性があります。

- CVE-2016-3960(XSA-173)クラウドセキュリティチームである Qihoo 360 の Ling Liu 氏および Yihan Lian 氏は、x86 シャドウページテーブルコードに整数オーバーフローがあることを発見しました。シャドウページテーブルを使用する HVM ゲストがホストをクラッシュさせる可能性があります。PV スーパーページが有効な(デフォルトではない)シャドウページテーブル (すなわち移行されている)を使用する PV ゲストが、ホストをクラッシュさせたり、ハイパーバイザーメモリを破損させたりする可能性があります。これにより権限昇格が発生する可能性があります。

ソリューション

xen パッケージをアップグレードしてください。

安定版(stable)ディストリビューション(jessie)では、これらの問題はバージョン 4.4.1-9+deb8u5 で修正されています。

関連情報

https://security-tracker.debian.org/tracker/CVE-2016-3158

https://security-tracker.debian.org/tracker/CVE-2016-3159

https://security-tracker.debian.org/tracker/CVE-2016-3960

https://packages.debian.org/source/jessie/xen

https://www.debian.org/security/2016/dsa-3554

プラグインの詳細

深刻度: High

ID: 90638

ファイル名: debian_DSA-3554.nasl

バージョン: 2.9

タイプ: local

エージェント: unix

公開日: 2016/4/22

更新日: 2021/1/11

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 6.5

CVSS v2

リスクファクター: High

Base Score: 7.2

Temporal Score: 5.3

ベクトル: AV:L/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:xen, cpe:/o:debian:debian_linux:8.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2016/4/21

参照情報

CVE: CVE-2016-3158, CVE-2016-3159, CVE-2016-3960

DSA: 3554