CentOS 6:ntp(CESA-2016: 0780)

high Nessus プラグイン ID 91169
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのCentOSホストに1つ以上のセキュリティ更新プログラムが欠落しています。

説明

ntp 用の更新が、Red Hat Enterprise Linux 6 で現在利用可能です。

Red Hat製品セキュリティは、この更新がセキュリティに及ぼす影響を重要度中と評価しています。詳細な重要度評価を示すCommon Vulnerability Scoring System (CVSS)ベーススコアは、「参照」セクションのCVEリンクから脆弱性ごとに入手できます。

NTP(ネットワークタイムプロトコル)は、コンピューターの時刻と別の参照される時刻ソースを同期させるために使用されます。これらのパッケージには、システム時間を継続的に調整するntpdサービスと、ntpdサービスをクエリおよび構成するために使用されるユーティリティが含まれます。

セキュリティ修正プログラム:

* CVE-2014-9750 の修正が不完全であることが判明しました:NTP の ntp_crypto.c の値の長さチェックに、3 つの問題が見つかりました。このため、悪意のあるデータが含まれる特定の autokey 操作を伴うパケットが、常に完全に検証されるとは限りませんでした。リモートの攻撃者が、特別に細工されたNTPパケットを利用してntpdをクラッシュさせる可能性があります。
(CVE-2015-7691、CVE-2015-7692、CVE-2015-7702)

* ntpd の CRYPTO_ASSOC にメモリリークの欠陥が見つかりました。ntpdがautokey認証を使用するように構成されていた場合、攻撃者がntpdにパケットを送信し、数日間の攻撃の実行によってメモリを枯渇させた可能性があります。(CVE-2015-7701)

* ntpqのcookedprint機能に、バッファオーバーフローを引き起こすoff-by-oneの欠陥が見つかりました。特別に細工されたNTPパケットにより、ntpqがクラッシュする可能性があります。(CVE-2015-7852)

* ntpdが、大量のエントリで制限リストを照会する「ntpdc reslist」コマンドを処理する方法で、NULLポインターデリファレンスの欠陥が見つかりました。リモートの攻撃者がこの欠陥を利用して、ntpdをクラッシュさせる可能性があります。(CVE-2015-7977)

* ntpdが、大量のエントリで制限リストを照会する「ntpdc reslist」コマンドを処理する方法で、スタックベースのバッファオーバーフローの欠陥が見つかりました。リモートの攻撃者がこの欠陥を利用して、ntpdをクラッシュさせる可能性があります。(CVE-2015-7978)

*不正な形式のlogconfig構成コマンドを処理するときに、初期化されていない変数により、ntpdがクラッシュする可能性があることがわかりました。
(CVE-2015-5194)

* コンパイル中に有効化されていない統計タイプ(例:
timingstats)が、統計またはfilegen構成コマンドによって参照される場合に、ntpdがセグメンテーション違反で終了する可能性があることがわかりました。(CVE-2015-5195)

* 細工されたNTPパケットを処理するときにsntpユーティリティが無限ループに陥ることにより、このユーティリティが無反応になる可能性があることがわかりました。(CVE-2015-5219)

* NTPの: configコマンドが、pidfileパスとdriftfileパスを設定するため、制限なしに使用される可能性があることがわかりました。リモートの攻撃者がこの欠陥を利用して、ntpdプロセスのpidを含むファイルを使用してファイルシステム上のファイルに上書きしたり(即時)、システムクロックの現在の推定ドリフトを(1時間の間隔で)上書きしたりする可能性があります。
(CVE-2015-7703)

CVE-2015-5219およびCVE-2015-7703の問題は、Miroslav Lichvár氏(Red Hat)により発見されました。

このリリースの変更に関する詳細については、「参照」セクションからリンクされているRed Hat Enterprise Linux 6.8リリースノートおよびRed Hat Enterprise Linux 6.8テクニカルノートを参照してください。

ソリューション

影響を受けるntpパッケージを更新してください。

関連情報

http://www.nessus.org/u?39e3e41a

https://www.tenable.com/security/research/tra-2015-04

プラグインの詳細

深刻度: High

ID: 91169

ファイル名: centos_RHSA-2016-0780.nasl

バージョン: 2.17

タイプ: local

エージェント: unix

公開日: 2016/5/17

更新日: 2021/1/4

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2015-7701

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:centos:centos:ntp, p-cpe:/a:centos:centos:ntp-doc, p-cpe:/a:centos:centos:ntp-perl, p-cpe:/a:centos:centos:ntpdate, cpe:/o:centos:centos:6

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2016/5/16

脆弱性公開日: 2017/1/30

参照情報

CVE: CVE-2015-5194, CVE-2015-5195, CVE-2015-5219, CVE-2015-7691, CVE-2015-7692, CVE-2015-7701, CVE-2015-7702, CVE-2015-7703, CVE-2015-7852, CVE-2015-7977, CVE-2015-7978