Debian DLA-822-1 : vim セキュリティ更新

critical Nessus プラグイン ID 97106

概要

リモートの Debian ホストにセキュリティ更新がありません。

説明

Vim で脆弱性が発見され、不正な形式のスペルファイルにより、メモリ割り当てのサイズとして使用される整数オーバーフローが引き起こされ、その後、バッファオーバーフローが発生する可能性があります。Debian 7 'Wheezy' では、これらの問題はバージョン 2:7.3.547-7+deb7u2 で修正されています。vim パッケージをアップグレードすることを推奨します。注 : Tenable Network Security は、前述の記述ブロックを DLA セキュリティアドバイザリから直接抽出しています。Tenableでは、新たな問題を持ち込まずに、できる限り自動的に整理して書式設定するようにしています。

ソリューション

影響を受けるパッケージをアップグレードしてください。

関連情報

https://lists.debian.org/debian-lts-announce/2017/02/msg00011.html

https://packages.debian.org/source/wheezy/vim

プラグインの詳細

深刻度: Critical

ID: 97106

ファイル名: debian_DLA-822.nasl

バージョン: 3.8

タイプ: local

エージェント: unix

公開日: 2017/2/13

更新日: 2021/1/11

サポートされているセンサー: Frictionless Assessment Agent, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:vim, p-cpe:/a:debian:debian_linux:vim-athena, p-cpe:/a:debian:debian_linux:vim-common, p-cpe:/a:debian:debian_linux:vim-dbg, p-cpe:/a:debian:debian_linux:vim-doc, p-cpe:/a:debian:debian_linux:vim-gnome, p-cpe:/a:debian:debian_linux:vim-gtk, p-cpe:/a:debian:debian_linux:vim-gui-common, p-cpe:/a:debian:debian_linux:vim-lesstif, p-cpe:/a:debian:debian_linux:vim-nox, p-cpe:/a:debian:debian_linux:vim-runtime, p-cpe:/a:debian:debian_linux:vim-tiny, cpe:/o:debian:debian_linux:7.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2017/2/13

参照情報

CVE: CVE-2017-5953