GLSA-201704-03:X.Org:複数の脆弱性

critical Nessus プラグイン ID 99276
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのGentooホストに1つ以上のセキュリティ関連のパッチがありません。

説明

リモートホストは、GLSA-201704-03(X.Org:複数の脆弱性)で説明されている脆弱性による影響を受けます。複数の脆弱性がX.Orgサーバーおよびライブラリで発見されています。詳細については、以下に記載されているCVE識別番号を参照してください。影響: ローカルまたはリモートのユーザーは、脆弱性を利用してユーザーとしてX.Orgセッションに接続し、任意のコードを実行できます。回避策:現時点では、既知の回避策はありません。

ソリューション

X.Org-serverの全ユーザーは、最新バージョンにアップグレードする必要があります:# emerge --sync # emerge --ask --oneshot --verbose '>=x11-base/xorg-server-1.19.2' libICEの全ユーザーは、最新バージョンにアップグレードする必要があります:# emerge --sync # emerge --ask --oneshot --verbose '>=x11-libs/libICE-1.0.9-r1' libXdmcpの全ユーザーは、最新バージョンにアップグレードする必要があります:# emerge --sync # emerge --ask --oneshot --verbose '>=x11-libs/libXdmcp-1.1.2-r1' libXrenderの全ユーザーは、最新バージョンにアップグレードする必要があります:# emerge --sync # emerge --ask --oneshot --verbose '>=x11-libs/libXrender-0.9.10' libXiの全ユーザーは、最新バージョンにアップグレードする必要があります:# emerge --sync # emerge --ask --oneshot --verbose '>=x11-libs/libXi-1.7.7' libXrandrの全ユーザーは、最新バージョンにアップグレードする必要があります:# emerge --sync # emerge --ask --oneshot --verbose '>=x11-libs/libXrandr-1.5.1' libXfixesの全ユーザーは、最新バージョンにアップグレードする必要があります:# emerge --sync # emerge --ask --oneshot --verbose '>=x11-libs/libXfixes-5.0.3' libXvの全ユーザーは、最新バージョンにアップグレードする必要があります:# emerge --sync # emerge --ask --oneshot --verbose '>=x11-libs/libXv-1.0.11'

関連情報

https://security.gentoo.org/glsa/201704-03

プラグインの詳細

深刻度: Critical

ID: 99276

ファイル名: gentoo_GLSA-201704-03.nasl

バージョン: 3.4

タイプ: local

公開日: 2017/4/11

更新日: 2021/1/11

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3

リスクファクター: Critical

Base Score: 9.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

脆弱性情報

CPE: p-cpe:/a:gentoo:linux:libICE, p-cpe:/a:gentoo:linux:libXdmcp, p-cpe:/a:gentoo:linux:libXfixes, p-cpe:/a:gentoo:linux:libXi, p-cpe:/a:gentoo:linux:libXrandr, p-cpe:/a:gentoo:linux:libXrender, p-cpe:/a:gentoo:linux:libXv, p-cpe:/a:gentoo:linux:xorg-server, cpe:/o:gentoo:linux

必要な KB アイテム: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

パッチ公開日: 2017/4/10

脆弱性公開日: 2016/12/13

参照情報

CVE: CVE-2016-5407, CVE-2016-7942, CVE-2016-7943, CVE-2016-7944, CVE-2016-7945, CVE-2016-7946, CVE-2016-7947, CVE-2016-7948, CVE-2016-7949, CVE-2016-7950, CVE-2016-7953, CVE-2017-2624, CVE-2017-2625, CVE-2017-2626

GLSA: 201704-03