Debian DLA-3053-1 : vim - LTS セキュリティ更新

high Nessus プラグイン ID 162406

概要

リモートの Debian ホストにセキュリティ関連の更新プログラムがありません。

説明

リモートの Debian 9 ホストには、dla-3053 のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- vimはヒープベースのバッファオーバーフローに対して脆弱です (CVE-2021-3903)

- 8.2より前の GitHub リポジトリ vim/vim のヒープベースのバッファオーバーフロー。(CVE-2022-0417)

- 8.2.4563より前の GitHub リポジトリ vim/vim における vim でヒープベースのバッファオーバーフローが発生します。(CVE-2022-0943)

- 8.2.4956より前の GitHub リポジトリ vim/vim における関数 grab_file_name のバッファオーバーリード。この脆弱性はソフトウェアのクラッシュ、メモリ改ざん、リモート実行の可能性があります。
(CVE-2022-1720)

- 8.2より前の GitHub リポジトリ vim/vim における領域外読み取り。(CVE-2022-1851、CVE-2022-2126)

- 8.2より前の GitHub リポジトリ vim/vim でのメモリ解放後使用 (Use-After-Free)。(CVE-2022-1898、CVE-2022-1968)

- 8.2より前の GitHub リポジトリ vim/vim におけるバッファオーバーリード。(CVE-2022-2124)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

vimパッケージをアップグレードしてください。

Debian 9 Stretch では、これらの問題はバージョン 2 で修正されています

関連情報

https://security-tracker.debian.org/tracker/source-package/vim

https://www.debian.org/lts/security/2022/dla-3053

https://security-tracker.debian.org/tracker/CVE-2021-3903

https://security-tracker.debian.org/tracker/CVE-2022-0417

https://security-tracker.debian.org/tracker/CVE-2022-0943

https://security-tracker.debian.org/tracker/CVE-2022-1720

https://security-tracker.debian.org/tracker/CVE-2022-1851

https://security-tracker.debian.org/tracker/CVE-2022-1898

https://security-tracker.debian.org/tracker/CVE-2022-1968

https://security-tracker.debian.org/tracker/CVE-2022-2124

https://security-tracker.debian.org/tracker/CVE-2022-2126

https://packages.debian.org/source/stretch/vim

プラグインの詳細

深刻度: High

ID: 162406

ファイル名: debian_DLA-3053.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2022/6/20

更新日: 2022/6/20

サポートされているセンサー: Frictionless Assessment Agent, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-1968

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:vim, p-cpe:/a:debian:debian_linux:vim-athena, p-cpe:/a:debian:debian_linux:vim-common, p-cpe:/a:debian:debian_linux:vim-doc, p-cpe:/a:debian:debian_linux:vim-gnome, p-cpe:/a:debian:debian_linux:vim-gtk, p-cpe:/a:debian:debian_linux:vim-gtk3, p-cpe:/a:debian:debian_linux:vim-gui-common, p-cpe:/a:debian:debian_linux:vim-nox, p-cpe:/a:debian:debian_linux:vim-runtime, p-cpe:/a:debian:debian_linux:vim-tiny, p-cpe:/a:debian:debian_linux:xxd, cpe:/o:debian:debian_linux:9.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/6/20

脆弱性公開日: 2021/10/27

参照情報

CVE: CVE-2021-3903, CVE-2022-0417, CVE-2022-0943, CVE-2022-1720, CVE-2022-1851, CVE-2022-1898, CVE-2022-1968, CVE-2022-2124, CVE-2022-2126