Atlassian Confluence < 7.4.17 / 7.5.x < 7.13.7 / 7.14.x < 7.14.3 / 7.15.x < 7.15.2 / 7.16.x < 7.16.4 / 7.17.x < 7.17.4 の XSS (CONFSERVER-79476)

critical Nessus プラグイン ID 163307

概要

リモートの Atlassian Confluence ホストにセキュリティ更新がありません。

説明

リモートホストにインストールされている Atlassian Confluence のバージョンは、< 7.4.17 / 7.5.x < 7.13.7 / 7.14.x < 7.14.3 / 7.15.x < 7.15.2 / 7.16.x < 7.16.4 / 7.17.x < 7.17.4 より前です。したがって、CONFSERVER-79476 のアドバイザリに記載されている脆弱性の影響を受けます。

- 複数のサーブレットフィルターの脆弱性が Confluence Server および Data Center で修正されました。これらの脆弱性は、他の Atlassian 製品にも影響を与えます。詳細については、[Atlassian のセキュリティアドバイザリ| https://confluence.atlassian.com/security/ multiple-products-security-advisory-cve-2022-26136-cve-2022-26137-1141493031.html]. h3. 任意のサーブレットフィルターバイパス (CVE-2022-26136) リモートの認証されていない攻撃者が、ファーストパーティおよびサードパーティのアプリが使用するサーブレットフィルターをバイパスする可能性があります。影響は、各アプリが使用するフィルター、およびフィルターの使用方法によって異なります。Atlassian は、この脆弱性の根本的な原因を修正する更新をリリースしましたが、この脆弱性の潜在的な結果をすべて網羅しているわけではありません。次の攻撃のみが確認されています。{*}認証バイパス{*}。特別に細工された HTTP リクエストを送信すると、サードパーティのアプリが認証を強制するために使用するカスタムサーブレットフィルターをバイパスする可能性があります。認証されていないリモートの攻撃者がこれを悪用して、サードパーティアプリが使用する認証をバイパスする可能性があります。注意 : Atlassian はこの攻撃が可能であることを確認していますが、影響を受けるすべてのアプリのリストを特定していません。{*}クロスサイトスクリプティング (XSS) {*}。特別に細工された HTTP リクエストを送信すると、正当な Atlassian ガジェットの検証に使用されるサーブレットフィルターがバイパスされ、XSS が引き起こされる可能性があります。ユーザーを騙して悪意のある URL をリクエストさせることのできる攻撃者が、ユーザーのブラウザで任意の Javascript を実行する可能性があります。h3。追加のサーブレットフィルター呼び出し (CVE-2022-26137) リモートの認証されていない攻撃者が、アプリケーションがリクエストまたは応答を処理するときに、追加のサーブレットフィルターを呼び出す可能性があります。Atlassian は、この脆弱性に関連する唯一の既知のセキュリティ問題を確認し、修正しました。{*}クロスオリジンリソース共有 (CORS) バイパス{*}。特別に細工された HTTP リクエストを送信すると、CORS リクエストへの応答に使用されるサーブレットフィルターが呼び出され、CORS バイパスが発生する可能性があります。ユーザーを騙して悪意のある URL をリクエストさせることのできる攻撃者が、被害者の権限で脆弱なアプリケーションにアクセスする可能性があります。 h3。影響を受けるバージョン : * バージョン < 7.4.17 * すべてのバージョン 7.5.x から 7.12.x * 7.13.x < 7.13.7 * 7.14.x < 7.14.3 * 7.15.x < 7.15.2 * 7.16.x < 7.16.4 * 7.17.x < 7.17.4 * 7.18.0 h3。修正済みバージョン : * 7.4.x >= 7.4.17 ([LTS|https://confluence.atlassian.com/enterprise/long-term-support-releases-948227420.html]) * 7.13.x >= 7.13.7 ([LTS|https://confluence.atlassian.com/enterprise/long-term-support-releases-948227420.html]) * 7.14.x >= 7.14.3 * 7.15.x >= 7.15.2 * 7.16.x >= 7.16.4 * 7.17.x >= 7.17.4 * バージョン >= 7.18.1 h3. 参照 [複数製品のセキュリティアドバイザリ 2022-07-20|https://confluence.atlassian.com/security/multiple-products-security-advisory-cve-2022-26136-cve-2022-26137-1141493031.html] (atlassian-CONFSERVER-79476)

Nessus はこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Atlassian Confluence バージョン 7.4.17、7.13.7、7.14.3、7.15.2、7.16.4、7.17.4 以降にアップグレードしてください。

関連情報

https://jira.atlassian.com/browse/CONFSERVER-79476

プラグインの詳細

深刻度: Critical

ID: 163307

ファイル名: confluence_confserver-79476.nasl

バージョン: 1.7

タイプ: remote

ファミリー: CGI abuses : XSS

公開日: 2022/7/20

更新日: 2022/10/5

構成: 徹底的なチェックを有効にする

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-26136

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:atlassian:confluence

必要な KB アイテム: installed_sw/confluence

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/7/5

脆弱性公開日: 2022/7/5

参照情報

CVE: CVE-2022-26136

IAVA: 2022-A-0293