Debian dsa-5685 : wordpress - セキュリティ更新

medium Nessus プラグイン ID 195202

概要

リモートの Debian ホストに 1 つ以上のセキュリティ関連の更新プログラムがありません。

説明

リモートの Debian 11 および 12 ホストには、dsa-5685 のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- WordPress Core は、6.2 以前のバージョンにおいて、wp_lang' パラメーターを介したディレクトリトラバーサルに対して脆弱です。これにより、認証されていない攻撃者が任意の翻訳ファイルにアクセスして読み込む可能性があります。
アップロードフォームなどを通じて、攻撃者が細工された翻訳ファイルをサイトにアップロードできる場合、これを利用してクロスサイトスクリプティング攻撃を実行する可能性もあります。(CVE-2023-2745)

- Auth. WordPress コアの次のバージョンに蓄積型 (contributor +) クロスサイトスクリプティング (XSS) の脆弱性が存在します。6.3 ~ 6.3.1、6.2 ~ 6.2.2、6.1 ~ 6.1.3、6.0 ~ 6.0.5、5.9 ~ 5.9.7、および Gutenberg プラグイン <= 16.8.0 バージョン。(CVE-2023-38000)

- WordPress 6.3 ~ 6.3.1、6.2 ~ 6.2.2、6.1 ~ 6.13、6.0 ~ 6.0.5、5.9 ~ 5.9.7、5.8 ~ 5.8.7、5.7 ~ 5.7.9、5.6 ~ 5.6.11、5.5 ~ 5.5.12、5.4 ~ 5.4.13、5.3 ~ 5.3.15、5.2 ~ 5.2.18、5.1 ~ 5.1.16、5.0 ~ 5.0.19、4.9 ~ 4.9.23、4.8 ~ 4.8.22、4.7 ~ 4.7.26、4.6 ~ 4.6.26、4.5 ~ 4.5.29、4.4 ~ 4.4.30、4.3 ~ 4.3.31、4.2 ~ 4.2.35、4.1 ~ 4.1.38 以降における認証されていない人物による機密情報の漏洩。(CVE-2023-39999)

- WordPress では、REST API 経由で検索可能なユーザーフィールドが適切に制限されないため、認証されていない攻撃者が、Oracle スタイルの攻撃の影響を受ける Web サイトで一般公開の投稿を公開しているユーザーのメールアドレスを識別してしまう可能性があります (CVE-2023-5561)

- WordPress は、ウェブ用のオープンな公開プラットフォームです。管理ユーザーは、WordPress の [プラグイン] > [新規追加] > [プラグインのアップロード] 画面から、zip ファイル以外の形式のファイルを新しいプラグインとして送信できます。インストール時に FTP 認証情報が要求された場合 (ファイルを「uploads」ディレクトリの外に移動するため)、アップロードされたファイルは、それが許可されていなくても、メディアライブラリで一時的に利用可能なままになります。サイトで「DISALLOW_FILE_EDIT」定数が「true」に設定され、
新しいテーマやプラグインをアップロードする際に FTP 資格情報が必要な場合に、仮にユーザーが任意の PHP コードを実行する手段を持たない場合でも、技術的には RCE が許可されます。この問題は、シングルサイトのインストールでは管理者レベルのユーザーにのみ影響し、マルチサイトのインストールでは、通常ユーザーが任意の PHP コードをアップロードまたは実行するアクセス許可を持たないと予想される場合には、スーパー管理者のユーザーにのみ影響します。より低いレベルのユーザーには影響を与えません。「DISALLOW_FILE_MODS」定数が「true」に設定されているサイトは影響を受けません。管理ユーザーが FTP 認証情報を入力する必要がない、または有効な FTP 認証情報にアクセスできるサイトは影響を受けません。この問題は 2024 年 1 月 30 日に WordPress 6.4.3 で修正され、バージョン 6.3.3、6.2.4、6.1.5、6.0.7、5.9.9、5.8.9、5.7.11、5.6.13、5.5.14、5.4.15、5.3.17、5.2.20、5.1.18、5.0.21、4.9.25、2.8.24、4.7.28、4.6.28、4.5.31、4.4.32、4.3.33、4.2.37、4.1.40 にバックポートされました。回避策が利用可能です。「DISALLOW_FILE_MODS」定数が「true」として定義されている場合、ユーザーはプラグインをアップロードできないため、この問題が悪用されることはありません。(CVE-2024-31210)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存していることに注意してください。

ソリューション

wordpress パッケージをアップグレードしてください。

参考資料

https://security-tracker.debian.org/tracker/source-package/wordpress

https://security-tracker.debian.org/tracker/CVE-2023-2745

https://security-tracker.debian.org/tracker/CVE-2023-38000

https://security-tracker.debian.org/tracker/CVE-2023-39999

https://security-tracker.debian.org/tracker/CVE-2023-5561

https://security-tracker.debian.org/tracker/CVE-2024-31210

https://packages.debian.org/source/bookworm/wordpress

https://packages.debian.org/source/bullseye/wordpress

プラグインの詳細

深刻度: Medium

ID: 195202

ファイル名: debian_DSA-5685.nasl

バージョン: 1.1

タイプ: local

エージェント: unix

公開日: 2024/5/9

更新日: 2024/5/31

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent, Nessus

リスク情報

VPR

リスクファクター: High

スコア: 7.3

CVSS v2

リスクファクター: Medium

基本値: 5.5

現状値: 4.3

ベクトル: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:N

CVSS スコアのソース: CVE-2023-38000

CVSS v3

リスクファクター: Medium

基本値: 5.4

現状値: 4.9

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

現状ベクトル: CVSS:3.0/E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:debian:debian_linux:11.0, p-cpe:/a:debian:debian_linux:wordpress, p-cpe:/a:debian:debian_linux:wordpress-theme-twentytwentythree, p-cpe:/a:debian:debian_linux:wordpress-l10n, p-cpe:/a:debian:debian_linux:wordpress-theme-twentytwenty, p-cpe:/a:debian:debian_linux:wordpress-theme-twentytwentytwo, p-cpe:/a:debian:debian_linux:wordpress-theme-twentynineteen, p-cpe:/a:debian:debian_linux:wordpress-theme-twentytwentyone, cpe:/o:debian:debian_linux:12.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2024/5/8

脆弱性公開日: 2023/5/17

参照情報

CVE: CVE-2023-2745, CVE-2023-38000, CVE-2023-39999, CVE-2023-5561, CVE-2024-31210

IAVA: 2023-A-0567-S