Debian DSA-2269-1:iceape - いくつかの脆弱性

critical Nessus プラグイン ID 55489
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのDebianホストにセキュリティ関連の更新プログラムがありません。

説明

SeaMonkey のノンブランドバージョン Iceape インターネットパッケージで、いくつかの脆弱性が見つかりました:

- CVE-2011-0083 / CVE-2011-2363 「regenrecht」は、SVG の処理で 2 件の use-after-free を発見しました。これは、任意のコードの実行を引き起こすことがあります。

- CVE-2011-0085 「regenrecht」は、XUL の処理で use-after-free を発見しました。これは、任意のコードの実行を引き起こすことがあります。

- CVE-2011-2362 David Chan 氏は、クッキーの隔離が不十分であることを発見しました。

- CVE-2011-2371 Chris Rohlf 氏と Yan Ivnitskiy 氏は、 JavaScript エンジンで整数オーバーフローを発見しました。これは、任意のコードの実行を引き起こすことがあります。

- CVE-2011-2373 Martin Barbella 氏は、XUL の処理で use-after-free を発見しました。これは、任意のコードの実行を引き起こすことがあります。

- CVE-2011-2374 Bob Clary 氏、Kevin Brosnan 氏、Nils 氏、Gary Kwong 氏、 Jesse Ruderman 氏、および Christian Biesinger 氏は、メモリ破損のバグを発見しました。これは、任意のコードの実行を引き起こすことがあります。

- CVE-2011-2376 Luke Wagner 氏と Gary Kwong 氏は、メモリ破損のバグを発見しました。これは、任意のコードの実行を引き起こすことがあります。

旧安定版(oldstable)ディストリビューション(lenny)は、影響を受けません。iceape パッケージは、 XPCOM コードのみ提供します。

ソリューション

iceape パッケージをアップグレードしてください。

安定版(stable)ディストリビューション(squeeze)の場合、この問題はバージョン 2.0.11-6 で修正済みです。

関連情報

https://security-tracker.debian.org/tracker/CVE-2011-0083

https://security-tracker.debian.org/tracker/CVE-2011-2363

https://security-tracker.debian.org/tracker/CVE-2011-0085

https://security-tracker.debian.org/tracker/CVE-2011-2362

https://security-tracker.debian.org/tracker/CVE-2011-2371

https://security-tracker.debian.org/tracker/CVE-2011-2373

https://security-tracker.debian.org/tracker/CVE-2011-2374

https://security-tracker.debian.org/tracker/CVE-2011-2376

https://packages.debian.org/source/squeeze/iceape

https://www.debian.org/security/2011/dsa-2269

プラグインの詳細

深刻度: Critical

ID: 55489

ファイル名: debian_DSA-2269.nasl

バージョン: 1.17

タイプ: local

エージェント: unix

公開日: 2011/7/5

更新日: 2021/1/4

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Critical

スコア: 9.7

CVSS v2

リスクファクター: Critical

Base Score: 10

ベクトル: AV:N/AC:L/Au:N/C:C/I:C/A:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:iceape, cpe:/o:debian:debian_linux:6.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2011/7/1

エクスプロイト可能

CANVAS (CANVAS)

Metasploit (Mozilla Firefox Array.reduceRight() Integer Overflow)

参照情報

CVE: CVE-2011-0083, CVE-2011-0085, CVE-2011-2362, CVE-2011-2363, CVE-2011-2365, CVE-2011-2371, CVE-2011-2373, CVE-2011-2374, CVE-2011-2376

DSA: 2269